aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPavel Kubelun <be.dissent@gmail.com>2016-12-20 11:39:00 +0300
committerFelix Fietkau <nbd@nbd.name>2016-12-22 16:42:20 +0100
commit0ee964f28407aca0934455f81bb4b9546f8a3c11 (patch)
tree278dc2583166c02156ceb82a145664ddf31e4f08
parentacfb06783500a6364b3e473b6c02d06156829f70 (diff)
downloadupstream-0ee964f28407aca0934455f81bb4b9546f8a3c11.tar.gz
upstream-0ee964f28407aca0934455f81bb4b9546f8a3c11.tar.bz2
upstream-0ee964f28407aca0934455f81bb4b9546f8a3c11.zip
ath10k-firmware: update qca9984 firmware
A new firmware that is available on code-aurora repository is newer than in Kvalo's repo. Taking into account that firmwares that are in Kvalo's repo are considered to be tested by internal QCA team, this one seems to be more stable and fixes this bug: ath10k_pci 0000:01:00.0: received unexpected tx_fetch_ind event: in push mode At least i havent faced it for a while in contradiction to current version. Thus switching firmware source for qca9984 until it or a newer version gets into Kvalo's repo. Signed-off-by: Pavel Kubelun <be.dissent@gmail.com>
-rw-r--r--package/firmware/ath10k-firmware/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/firmware/ath10k-firmware/Makefile b/package/firmware/ath10k-firmware/Makefile
index 6af597f57f..b557c822ac 100644
--- a/package/firmware/ath10k-firmware/Makefile
+++ b/package/firmware/ath10k-firmware/Makefile
@@ -179,6 +179,18 @@ define Download/qca99x0-board
endef
$(eval $(call Download,qca99x0-board))
+QCA9984_FIRMWARE_REV:=deb1832c56c706d0f6cb539113e09f0daaa52b5f
+QCA9984_FIRMWARE_FILE:=firmware-5.bin_10.4-3.3-00102
+QCA9984_FIRMWARE_FILE_DL:=$(QCA9984_FIRMWARE_FILE).$(QCA9984_FIRMWARE_REV)
+
+define Download/ath10k-qca9984-firmware
+ URL:=https://source.codeaurora.org/quic/qsdk/oss/firmware/ath10k-firmware/plain/ath10k/QCA9984/hw1.0/
+ URL_FILE:=$(QCA9984_FIRMWARE_FILE)?id=$(QCA9984_FIRMWARE_REV)
+ FILE:=$(QCA9984_FIRMWARE_FILE_DL)
+ HASH:=490ad52df76a4fa8004a3a8c21dd43bb8262dd2816df48a6408706b82491f299
+endef
+$(eval $(call Download,ath10k-qca9984-firmware))
+
define Build/Compile
endef
@@ -253,7 +265,7 @@ define Package/ath10k-firmware-qca9984/install
$(PKG_BUILD_DIR)/QCA9984/hw1.0/board-2.bin \
$(1)/lib/firmware/ath10k/QCA9984/hw1.0/board-2.bin
$(INSTALL_DATA) \
- $(PKG_BUILD_DIR)/QCA9984/hw1.0/3.3/firmware-5.bin_10.4-3.3-00092 \
+ $(DL_DIR)/$(QCA9984_FIRMWARE_FILE_DL) \
$(1)/lib/firmware/ath10k/QCA9984/hw1.0/firmware-5.bin
endef