diff options
author | Felix Fietkau <nbd@nbd.name> | 2017-01-22 13:30:39 +0100 |
---|---|---|
committer | Felix Fietkau <nbd@nbd.name> | 2017-01-22 13:31:54 +0100 |
commit | 2990a21058243b067bb56fed36ee69205595993e (patch) | |
tree | 500ca7bc63912d4c54891232000d882c81c00d3a | |
parent | f798776188eaf1a9c0345da66a848a5cbe3cfb71 (diff) | |
download | upstream-2990a21058243b067bb56fed36ee69205595993e.tar.gz upstream-2990a21058243b067bb56fed36ee69205595993e.tar.bz2 upstream-2990a21058243b067bb56fed36ee69205595993e.zip |
build: always run package/cleanup before package/compile
Remove unnecessary stampfile indirection
Fixes an issue with the command sequence used by buildbot
Signed-off-by: Felix Fietkau <nbd@nbd.name>
-rw-r--r-- | Makefile | 2 | ||||
-rw-r--r-- | package/Makefile | 3 |
2 files changed, 3 insertions, 2 deletions
@@ -41,7 +41,7 @@ else $(toolchain/stamp-compile): $(tools/stamp-compile) $(target/stamp-compile): $(toolchain/stamp-compile) $(tools/stamp-compile) $(BUILD_DIR)/.prepared -$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup) +$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-install): $(package/stamp-compile) $(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) check: $(tools/stamp-check) $(toolchain/stamp-check) $(package/stamp-check) diff --git a/package/Makefile b/package/Makefile index 6929c479a2..b5e4bfa12b 100644 --- a/package/Makefile +++ b/package/Makefile @@ -49,6 +49,8 @@ PACKAGE_INSTALL_FILES:= \ $(curdir)/cleanup: $(TMP_DIR)/.build rm -rf $(STAGING_DIR_ROOT) +$(curdir)/compile: $(curdir)/cleanup + $(curdir)/merge: rm -rf $(PACKAGE_DIR_ALL) mkdir -p $(PACKAGE_DIR_ALL) @@ -98,7 +100,6 @@ $(curdir)/preconfig: $(curdir)/flags-install:= -j1 $(eval $(call stampfile,$(curdir),package,prereq,.config)) -$(eval $(call stampfile,$(curdir),package,cleanup,$(TMP_DIR)/.build)) $(eval $(call stampfile,$(curdir),package,compile,$(TMP_DIR)/.build)) $(eval $(call stampfile,$(curdir),package,install,$(TMP_DIR)/.build)) $(eval $(call stampfile,$(curdir),package,check,$(TMP_DIR)/.build)) |