aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-04-15 02:08:11 +0000
committerNicolas Thill <nico@openwrt.org>2008-04-15 02:08:11 +0000
commit2a4a0c2bcccdd56d23bd00aabb457da21876eb3a (patch)
treeb0fe32c81da46cd261869152678f446604d28a96
parentd07eb95838190f3bcd7f0528e519e988be5735af (diff)
downloadupstream-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.tar.gz
upstream-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.tar.bz2
upstream-2a4a0c2bcccdd56d23bd00aabb457da21876eb3a.zip
explicitely disable a bunch of package on ar7 until we properly detect pci & usb support at configure time
SVN-Revision: 10839
-rw-r--r--package/mac80211/Makefile4
-rw-r--r--package/madwifi/Makefile6
-rw-r--r--package/p54/Makefile8
3 files changed, 11 insertions, 7 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 9370b1d113..749c8c1714 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -19,6 +19,8 @@ PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
+
define KernelPackage/mac80211
SUBMENU:=Wireless Drivers
TITLE:=Linux 802.11 Wireless Networking Stack
@@ -54,7 +56,7 @@ $(eval $(call Download,rt71w))
define KernelPackage/rt2x00/Default
SUBMENU:=Wireless Drivers
TITLE:=Ralink Drivers for RT2x00 cards
- DEPENDS:=@LINUX_2_6_24 @!TARGET_atheros @!TARGET_uml
+ DEPENDS:=@LINUX_2_6_24 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
endef
define KernelPackage/rt2x00-lib
diff --git a/package/madwifi/Makefile b/package/madwifi/Makefile
index f2fdac7b9d..d502e33f59 100644
--- a/package/madwifi/Makefile
+++ b/package/madwifi/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -59,7 +59,7 @@ else
endif
# XXX: remove this check later when we have PCI support properly detected on all targets
-ifneq ($(CONFIG_TARGET_uml),)
+ifneq ($(CONFIG_TARGET_ar7)$(CONFIG_TARGET_uml),)
BUS:=
endif
@@ -108,7 +108,7 @@ define KernelPackage/madwifi
SUBMENU:=Wireless Drivers
TITLE:=Driver for Atheros wireless chipsets
URL:=http://madwifi.org/
- DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
+ DEPENDS:=+wireless-tools @PCI_SUPPORT||TARGET_atheros @!TARGET_ar7 @!TARGET_avr32 @!TARGET_etrax @!TARGET_uml
FILES:=$(MADWIFI_FILES)
AUTOLOAD:=$(call AutoLoad,50,$(MADWIFI_AUTOLOAD))
endef
diff --git a/package/p54/Makefile b/package/p54/Makefile
index c282a09bf1..df2e40433b 100644
--- a/package/p54/Makefile
+++ b/package/p54/Makefile
@@ -1,10 +1,10 @@
#
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
-# $Id: $
+# $Id$
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
@@ -18,10 +18,12 @@ PKG_FWP54_MD5SUM:=09f9da7ea757173c9de1a0322a1f9782
include $(INCLUDE_DIR)/package.mk
+# XXX: remove @!TARGET_* later when we have PCI & USB support properly detected on all targets
+
define KernelPackage/p54/Default
SUBMENU:=Wireless Drivers
TITLE:=Prism Wireless Support (mac80211)
- DEPENDS:=+kmod-mac80211 @!TARGET_atheros @!TARGET_uml
+ DEPENDS:=+kmod-mac80211 @!TARGET_ar7 @!TARGET_atheros @!TARGET_uml
endef
define KernelPackage/p54-common