aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 19:55:54 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 19:55:54 +0000
commit42d657027e98eacafa1c32e0dab4d7a60de6f891 (patch)
treecf1c274b03893abf6087c4a7cc0e777a68c372d1
parent343946f7a7da0f256dafd572b6bad54ea3dc3d8f (diff)
downloadupstream-42d657027e98eacafa1c32e0dab4d7a60de6f891.tar.gz
upstream-42d657027e98eacafa1c32e0dab4d7a60de6f891.tar.bz2
upstream-42d657027e98eacafa1c32e0dab4d7a60de6f891.zip
fix gcc compile
SVN-Revision: 5032
-rw-r--r--openwrt/rules.mk4
-rw-r--r--openwrt/toolchain/gcc/Makefile1
2 files changed, 4 insertions, 1 deletions
diff --git a/openwrt/rules.mk b/openwrt/rules.mk
index 8e5294edb3..b9859dbd3f 100644
--- a/openwrt/rules.mk
+++ b/openwrt/rules.mk
@@ -8,7 +8,9 @@
-include $(TOPDIR)/.config
include $(TOPDIR)/include/verbose.mk
-export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+export BASH=$(shell which bash)
+
ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
WGET:=$(strip $(subst ",, $(CONFIG_WGET)))
diff --git a/openwrt/toolchain/gcc/Makefile b/openwrt/toolchain/gcc/Makefile
index 8a23375933..7ef6005d06 100644
--- a/openwrt/toolchain/gcc/Makefile
+++ b/openwrt/toolchain/gcc/Makefile
@@ -45,6 +45,7 @@ include $(INCLUDE_DIR)/host-build.mk
BUILD_DIR1:=$(TOOLCHAIN_BUILD_DIR)/gcc-$(PKG_VERSION)-initial
BUILD_DIR2:=$(TOOLCHAIN_BUILD_DIR)/gcc-$(PKG_VERSION)-final
+override SHELL:=$(BASH)
define Stage1/Configure
mkdir -p $(BUILD_DIR1)