aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-11-07 18:12:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-11-07 18:12:11 +0000
commit439b8bac004b39878f4db038d8730887edd115ba (patch)
tree040ea5c1899822d6690f6bcfd662c711509a7a58
parente540137ee3d164b18275fc71508c80b55fd207a8 (diff)
downloadupstream-439b8bac004b39878f4db038d8730887edd115ba.tar.gz
upstream-439b8bac004b39878f4db038d8730887edd115ba.tar.bz2
upstream-439b8bac004b39878f4db038d8730887edd115ba.zip
more cosmetic makefile fixes
SVN-Revision: 2387
-rw-r--r--openwrt/package/base-files/Makefile3
-rw-r--r--openwrt/package/cifsmount/Makefile2
-rw-r--r--openwrt/package/libamsel/Makefile3
-rw-r--r--openwrt/package/mtd/Makefile5
4 files changed, 11 insertions, 2 deletions
diff --git a/openwrt/package/base-files/Makefile b/openwrt/package/base-files/Makefile
index adf2ffbb57..48099c9470 100644
--- a/openwrt/package/base-files/Makefile
+++ b/openwrt/package/base-files/Makefile
@@ -30,6 +30,9 @@ $(PKG_BUILD_DIR)/.prepared:
mkdir -p $(PKG_BUILD_DIR) $(PACKAGE_DIR)
touch $@
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
$(PKG_BUILD_DIR)/.built:
touch $@
diff --git a/openwrt/package/cifsmount/Makefile b/openwrt/package/cifsmount/Makefile
index 2cb64d45fc..e435423fe3 100644
--- a/openwrt/package/cifsmount/Makefile
+++ b/openwrt/package/cifsmount/Makefile
@@ -13,7 +13,7 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,CIFSMOUNT,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.prepared:
- mkdir -p $@
+ mkdir -p $(PKG_BUILD_DIR)
touch $@
$(PKG_BUILD_DIR)/.configured:
diff --git a/openwrt/package/libamsel/Makefile b/openwrt/package/libamsel/Makefile
index a14aa0470f..530582f3ce 100644
--- a/openwrt/package/libamsel/Makefile
+++ b/openwrt/package/libamsel/Makefile
@@ -18,6 +18,9 @@ include $(TOPDIR)/package/rules.mk
$(eval $(call PKG_template,LIBAMSEL,libamsel,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
$(PKG_BUILD_DIR)/.built:
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
diff --git a/openwrt/package/mtd/Makefile b/openwrt/package/mtd/Makefile
index 18ebc90335..0ff1945b40 100644
--- a/openwrt/package/mtd/Makefile
+++ b/openwrt/package/mtd/Makefile
@@ -13,7 +13,10 @@ $(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
$(eval $(call PKG_template,MTD_STATIC,mtd-static,$(PKG_RELEASE),$(ARCH)))
$(PKG_BUILD_DIR)/.prepared:
- mkdir -p $@
+ mkdir -p $(PKG_BUILD_DIR)
+ touch $@
+
+$(PKG_BUILD_DIR)/.configured:
touch $@
$(PKG_BUILD_DIR)/.built: