aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-11-26 14:22:11 +0000
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-11-26 17:32:43 +0000
commit4420ddaa5893acf524577b05bb0871e6f9d8735c (patch)
treed4b2e1d707e5b4e248e8f155e818777e70a12610
parent18a53d43d646290053eff4736ec852efcf6bf510 (diff)
downloadupstream-4420ddaa5893acf524577b05bb0871e6f9d8735c.tar.gz
upstream-4420ddaa5893acf524577b05bb0871e6f9d8735c.tar.bz2
upstream-4420ddaa5893acf524577b05bb0871e6f9d8735c.zip
kernel: clean up patch fuzz
Recent kernel bumps & target patch refactors have left some patch fuzz around. Refreshed kernel patches using update_kernel script. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
-rw-r--r--target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch2
-rw-r--r--target/linux/bcm27xx/patches-5.4/950-0027-mm-Remove-the-PFN-busy-warning.patch2
-rw-r--r--target/linux/bcm27xx/patches-5.4/950-0653-spi-Force-CS_HIGH-if-GPIO-descriptors-are-used.patch4
-rw-r--r--target/linux/bcm27xx/patches-5.4/950-0697-SQUASH-spi-Demote-SPI_CS_HIGH-warning-to-KERN_DEBUG.patch2
-rw-r--r--target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch12
-rw-r--r--target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch12
-rw-r--r--target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch6
-rw-r--r--target/linux/realtek/patches-5.4/705-add-rtl-phy.patch6
-rw-r--r--target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch2
9 files changed, 18 insertions, 30 deletions
diff --git a/target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch b/target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
index e5aa9dccc6..16317114dc 100644
--- a/target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
+++ b/target/linux/ath79/patches-5.4/910-unaligned_access_hacks.patch
@@ -754,7 +754,7 @@
ptr = ip6hoff + sizeof(struct ipv6hdr);
--- a/include/net/neighbour.h
+++ b/include/net/neighbour.h
-@@ -273,8 +273,10 @@ static inline bool neigh_key_eq128(const
+@@ -274,8 +274,10 @@ static inline bool neigh_key_eq128(const
const u32 *n32 = (const u32 *)n->primary_key;
const u32 *p32 = pkey;
diff --git a/target/linux/bcm27xx/patches-5.4/950-0027-mm-Remove-the-PFN-busy-warning.patch b/target/linux/bcm27xx/patches-5.4/950-0027-mm-Remove-the-PFN-busy-warning.patch
index b8c9ed0c80..0ca1cb7e06 100644
--- a/target/linux/bcm27xx/patches-5.4/950-0027-mm-Remove-the-PFN-busy-warning.patch
+++ b/target/linux/bcm27xx/patches-5.4/950-0027-mm-Remove-the-PFN-busy-warning.patch
@@ -14,7 +14,7 @@ Signed-off-by: Eric Anholt <eric@anholt.net>
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
-@@ -8489,8 +8489,6 @@ int alloc_contig_range(unsigned long sta
+@@ -8511,8 +8511,6 @@ int alloc_contig_range(unsigned long sta
/* Make sure the range is really isolated. */
if (test_pages_isolated(outer_start, end, false)) {
diff --git a/target/linux/bcm27xx/patches-5.4/950-0653-spi-Force-CS_HIGH-if-GPIO-descriptors-are-used.patch b/target/linux/bcm27xx/patches-5.4/950-0653-spi-Force-CS_HIGH-if-GPIO-descriptors-are-used.patch
index c6dfba6e43..69602fa17e 100644
--- a/target/linux/bcm27xx/patches-5.4/950-0653-spi-Force-CS_HIGH-if-GPIO-descriptors-are-used.patch
+++ b/target/linux/bcm27xx/patches-5.4/950-0653-spi-Force-CS_HIGH-if-GPIO-descriptors-are-used.patch
@@ -23,7 +23,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
--- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c
-@@ -3058,6 +3058,7 @@ static int __spi_validate_bits_per_word(
+@@ -3114,6 +3114,7 @@ static int __spi_validate_bits_per_word(
*/
int spi_setup(struct spi_device *spi)
{
@@ -31,7 +31,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
unsigned bad_bits, ugly_bits;
int status;
-@@ -3075,6 +3076,14 @@ int spi_setup(struct spi_device *spi)
+@@ -3131,6 +3132,14 @@ int spi_setup(struct spi_device *spi)
(SPI_TX_DUAL | SPI_TX_QUAD | SPI_TX_OCTAL |
SPI_RX_DUAL | SPI_RX_QUAD | SPI_RX_OCTAL)))
return -EINVAL;
diff --git a/target/linux/bcm27xx/patches-5.4/950-0697-SQUASH-spi-Demote-SPI_CS_HIGH-warning-to-KERN_DEBUG.patch b/target/linux/bcm27xx/patches-5.4/950-0697-SQUASH-spi-Demote-SPI_CS_HIGH-warning-to-KERN_DEBUG.patch
index eeab139956..2bf0f1a267 100644
--- a/target/linux/bcm27xx/patches-5.4/950-0697-SQUASH-spi-Demote-SPI_CS_HIGH-warning-to-KERN_DEBUG.patch
+++ b/target/linux/bcm27xx/patches-5.4/950-0697-SQUASH-spi-Demote-SPI_CS_HIGH-warning-to-KERN_DEBUG.patch
@@ -15,7 +15,7 @@ Signed-off-by: Phil Elwell <phil@raspberrypi.com>
--- a/drivers/spi/spi.c
+++ b/drivers/spi/spi.c
-@@ -3070,8 +3070,8 @@ int spi_setup(struct spi_device *spi)
+@@ -3126,8 +3126,8 @@ int spi_setup(struct spi_device *spi)
if (ctlr->use_gpio_descriptors && ctlr->cs_gpiods &&
ctlr->cs_gpiods[spi->chip_select] && !(spi->mode & SPI_CS_HIGH)) {
diff --git a/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch b/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
index 2c4f062792..e946a5b1a0 100644
--- a/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
+++ b/target/linux/realtek/patches-5.4/300-mips-add-rtl838x-platform.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/arch/mips/Kbuild.platforms
-===================================================================
---- linux-5.4.77.orig/arch/mips/Kbuild.platforms
-+++ linux-5.4.77/arch/mips/Kbuild.platforms
+--- a/arch/mips/Kbuild.platforms
++++ b/arch/mips/Kbuild.platforms
@@ -27,6 +27,7 @@ platforms += pistachio
platforms += pmcs-msp71xx
platforms += pnx833x
@@ -10,10 +8,8 @@ Index: linux-5.4.77/arch/mips/Kbuild.platforms
platforms += rb532
platforms += sgi-ip22
platforms += sgi-ip27
-Index: linux-5.4.77/arch/mips/Kconfig
-===================================================================
---- linux-5.4.77.orig/arch/mips/Kconfig
-+++ linux-5.4.77/arch/mips/Kconfig
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
@@ -630,6 +630,26 @@ config RALINK
select ARCH_HAS_RESET_CONTROLLER
select RESET_CONTROLLER
diff --git a/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch b/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
index 20602076b2..bb6f83e55d 100644
--- a/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
+++ b/target/linux/realtek/patches-5.4/700-net-dsa-add-support-for-rtl838x-switch.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/drivers/net/dsa/Kconfig
-===================================================================
---- linux-5.4.77.orig/drivers/net/dsa/Kconfig
-+++ linux-5.4.77/drivers/net/dsa/Kconfig
+--- a/drivers/net/dsa/Kconfig
++++ b/drivers/net/dsa/Kconfig
@@ -63,6 +63,8 @@ config NET_DSA_QCA8K
This enables support for the Qualcomm Atheros QCA8K Ethernet
switch chips.
@@ -11,10 +9,8 @@ Index: linux-5.4.77/drivers/net/dsa/Kconfig
config NET_DSA_REALTEK_SMI
tristate "Realtek SMI Ethernet switch family support"
depends on NET_DSA
-Index: linux-5.4.77/drivers/net/dsa/Makefile
-===================================================================
---- linux-5.4.77.orig/drivers/net/dsa/Makefile
-+++ linux-5.4.77/drivers/net/dsa/Makefile
+--- a/drivers/net/dsa/Makefile
++++ b/drivers/net/dsa/Makefile
@@ -21,3 +21,4 @@ obj-y += b53/
obj-y += microchip/
obj-y += mv88e6xxx/
diff --git a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
index 9d4140c8e1..c8a09c50d3 100644
--- a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
+++ b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/net/dsa/tag_trailer.c
-===================================================================
---- linux-5.4.77.orig/net/dsa/tag_trailer.c
-+++ linux-5.4.77/net/dsa/tag_trailer.c
+--- a/net/dsa/tag_trailer.c
++++ b/net/dsa/tag_trailer.c
@@ -44,7 +44,12 @@ static struct sk_buff *trailer_xmit(stru
trailer = skb_put(nskb, 4);
diff --git a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
index 5c5d08fe9f..826891abe1 100644
--- a/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
+++ b/target/linux/realtek/patches-5.4/705-add-rtl-phy.patch
@@ -1,7 +1,5 @@
-Index: linux-5.4.77/drivers/net/phy/Makefile
-===================================================================
---- linux-5.4.77.orig/drivers/net/phy/Makefile
-+++ linux-5.4.77/drivers/net/phy/Makefile
+--- a/drivers/net/phy/Makefile
++++ b/drivers/net/phy/Makefile
@@ -101,7 +101,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc.o
obj-$(CONFIG_NATIONAL_PHY) += national.o
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
diff --git a/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch b/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
index c74f78b0b0..ca6deb74d8 100644
--- a/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
+++ b/target/linux/realtek/patches-5.4/705-include-linux-phy-increase-phy-address-number-for-rtl839x.patch
@@ -1,6 +1,6 @@
--- a/include/linux/phy.h
+++ b/include/linux/phy.h
-@@ -188,7 +188,7 @@
+@@ -188,7 +188,7 @@ static inline const char *phy_modes(phy_
#define PHY_INIT_TIMEOUT 100000
#define PHY_FORCE_TIMEOUT 10