aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-10-16 11:22:04 +0800
committerJohn Crispin <john@phrozen.org>2017-11-10 23:00:47 +0100
commit47cff4cf5f85b001cb0eed4679d4938ae07cdfaa (patch)
tree75b2a140ff5eec1db72f6daff583434a6e6b8046
parente47c93bb19d8cbf195cf3a51c149454eec15391a (diff)
downloadupstream-47cff4cf5f85b001cb0eed4679d4938ae07cdfaa.tar.gz
upstream-47cff4cf5f85b001cb0eed4679d4938ae07cdfaa.tar.bz2
upstream-47cff4cf5f85b001cb0eed4679d4938ae07cdfaa.zip
layerscape: support all-in-one firmware for ls1088ardb/ls2088ardb
Suppport all-in-one firmware for ls1088ardb/ls2088ardb by integrating u-boot/rcw/mc/dpl/restool. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
-rw-r--r--package/boot/uboot-layerscape/Makefile14
-rw-r--r--package/firmware/layerscape/rcw/Makefile14
-rw-r--r--target/linux/layerscape/image/Makefile40
3 files changed, 58 insertions, 10 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 01ebd6e511..ce390cc6b4 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -42,10 +42,22 @@ define U-Boot/ls1012ardb
UBOOT_CONFIG:=ls1012ardb_qspi
endef
+define U-Boot/ls1088ardb
+ NAME:=NXP ls1088ardb 64b Dev Board
+ UBOOT_CONFIG:=ls1088ardb_qspi
+endef
+
+define U-Boot/ls2088ardb
+ NAME:=NXP ls2088ardb 64b Dev Board
+ UBOOT_CONFIG:=ls2080ardb
+endef
+
UBOOT_TARGETS := \
ls1043ardb \
ls1046ardb \
- ls1012ardb
+ ls1012ardb \
+ ls1088ardb \
+ ls2088ardb
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
diff --git a/package/firmware/layerscape/rcw/Makefile b/package/firmware/layerscape/rcw/Makefile
index a065385189..652e55ccca 100644
--- a/package/firmware/layerscape/rcw/Makefile
+++ b/package/firmware/layerscape/rcw/Makefile
@@ -46,10 +46,22 @@ define rcw/ls1012ardb
CONFIG=ls1012ardb/R_SPNH_3508/PBL_0x35_0x08_800_250_1000_default.bin
endef
+define rcw/ls1088ardb
+ TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1088ardb 64b/32b Dev Board
+ CONFIG=ls1088ardb/FCQQQQQQQQ_PPP_H_0x1d_0x0d/PBL_QSPI_1600_700_2100_0x1d_0x0d.bin
+endef
+
+define rcw/ls2088ardb
+ TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls2088ardb 64b/32b Dev Board
+ CONFIG=ls2088ardb/FFFFFFFF_PP_HH_0x2a_0x41/PBL_0x2a_0x41_1800_700_1866_1600.bin
+endef
+
RCWS := \
ls1043ardb \
ls1046ardb \
- ls1012ardb
+ ls1012ardb \
+ ls1088ardb \
+ ls2088ardb
define Package/rcw/template
define Package/rcw-layerscape-$(1)
diff --git a/target/linux/layerscape/image/Makefile b/target/linux/layerscape/image/Makefile
index 5577b16238..165ed0e98f 100644
--- a/target/linux/layerscape/image/Makefile
+++ b/target/linux/layerscape/image/Makefile
@@ -20,6 +20,18 @@ define Build/append-ls-fman
dd if=$(STAGING_DIR_IMAGE)/$(1)-fman.bin >> $@
endef
+define Build/append-ls-mc
+ dd if=$(STAGING_DIR_IMAGE)/$(1)-mc.itb >> $@
+endef
+
+define Build/append-ls-dpl
+ dd if=$(STAGING_DIR_IMAGE)/$(1)-dpl.dtb >> $@
+endef
+
+define Build/append-ls-dpc
+ dd if=$(STAGING_DIR_IMAGE)/$(1)-dpc.dtb >> $@
+endef
+
define Build/append-ls-dtb
$(call Image/BuildDTB,$(DTS_DIR)/$(1).dts,$(DTS_DIR)/$(1).dtb)
dd if=$(DTS_DIR)/$(1).dtb >> $@
@@ -90,21 +102,33 @@ TARGET_DEVICES += ls1012ardb
ifeq ($(SUBTARGET),armv8_64b)
define Device/ls1088ardb
DEVICE_TITLE := ls1088ardb-$(SUBTARGET)
- DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb mc-binary-ls1088ardb
+ DEVICE_PACKAGES += rcw-layerscape-ls1088ardb uboot-layerscape-$(SUBTARGET)-ls1088ardb \
+ layerscape-mc-ls1088ardb layerscape-dpl-ls1088ardb restool
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls1088a-rdb
- IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | \
- append-kernel | pad-to 17M | \
- append-ls-rootfs-ext4 $(1) 17M | check-size 51380225
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-mc $(1) | pad-to 13M | \
+ append-ls-dpl $(1) | pad-to 14M | \
+ append-ls-dpc $(1) | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-ls-rootfs-ext4 $(1) 17M | check-size 67108865
endef
TARGET_DEVICES += ls1088ardb
define Device/ls2088ardb
DEVICE_TITLE := ls2088ardb-$(SUBTARGET)
- DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb mc-binary-ls2088ardb
+ DEVICE_PACKAGES += rcw-layerscape-ls2088ardb uboot-layerscape-$(SUBTARGET)-ls2088ardb \
+ layerscape-mc-ls2088ardb layerscape-dpl-ls2088ardb restool
DEVICE_DTS = ../../../arm64/boot/dts/freescale/fsl-ls2088a-rdb
- IMAGE/firmware.bin = append-ls-dtb $$(DEVICE_DTS) | pad-to 1M | \
- append-kernel | pad-to 17M | \
- append-rootfs | pad-rootfs | check-size 51380225
+ IMAGE/firmware.bin = append-ls-rcw $(1) | pad-to 1M | \
+ append-ls-uboot $(1) | pad-to 10M | \
+ append-ls-mc $(1) | pad-to 13M | \
+ append-ls-dpl $(1) | pad-to 14M | \
+ append-ls-dpc $(1) | pad-to 15M | \
+ append-ls-dtb $$(DEVICE_DTS) | pad-to 16M | \
+ append-kernel | pad-to 32M | \
+ append-rootfs | pad-rootfs | check-size 67108865
endef
TARGET_DEVICES += ls2088ardb
endif