aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergei Burakov <senior.anonymous@ya.ru>2020-05-28 21:24:55 +0300
committerPetr Štetiar <ynezz@true.cz>2020-07-08 22:52:40 +0200
commit4dc9ad4af8c921494d20b303b6772fc6b5af3a69 (patch)
tree13f41b19074efd87c7c7a61f85c6fe0435b9577a
parent9e6257c26ca29a6040f55c517030e04be95005f2 (diff)
downloadupstream-4dc9ad4af8c921494d20b303b6772fc6b5af3a69.tar.gz
upstream-4dc9ad4af8c921494d20b303b6772fc6b5af3a69.tar.bz2
upstream-4dc9ad4af8c921494d20b303b6772fc6b5af3a69.zip
ramips: add support for ZyXEL Keenetic Lite Rev.B
Device specification: SoC: RT5350 CPU Frequency: 360 MHz Flash Chip: Macronix MX25L6406E (8192 KiB) RAM: Winbond W9825G6JH-6 (32768 KiB) 5x 10/100 Mbps Ethernet (4x LAN, 1x WAN) 1x external antenna UART (J1) header on PCB (57800 8n1) Wireless: SoC-intergated: 2.4GHz 802.11bgn USB: None 8x LED, 2x button Flash instruction: Configure PC with static IP 192.168.99.8/24 and start TFTP server. Rename "openwrt-ramips-rt305x-zyxel_keenetic-lite-b-squashfs-sysupgrade.bin" to "rt305x_firmware.bin" and place it in TFTP server directory. Connect PC with one of LAN ports, press the reset button, power up the router and keep button pressed until power LED start blinking. Router will download file from TFTP server, write it to flash and reboot. Signed-off-by: Sergei Burakov <senior.anonymous@ya.ru>
-rw-r--r--target/linux/ramips/dts/rt5350_zyxel_keenetic-lite-b.dts110
-rw-r--r--target/linux/ramips/image/rt305x.mk9
-rwxr-xr-xtarget/linux/ramips/rt305x/base-files/etc/board.d/02_network1
3 files changed, 120 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/rt5350_zyxel_keenetic-lite-b.dts b/target/linux/ramips/dts/rt5350_zyxel_keenetic-lite-b.dts
new file mode 100644
index 0000000000..74c7fa920f
--- /dev/null
+++ b/target/linux/ramips/dts/rt5350_zyxel_keenetic-lite-b.dts
@@ -0,0 +1,110 @@
+// SPDX-License-Identifier: GPL-2.0-or-later
+/dts-v1/;
+
+#include "rt5350.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "zyxel,keenetic-lite-b", "ralink,rt5350-soc";
+ model = "ZyXEL Keenetic Lite Rev.B";
+
+ aliases {
+ led-boot = &led_power;
+ led-failsafe = &led_power;
+ led-running = &led_power;
+ led-upgrade = &led_power;
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_power: power {
+ label = "keenetic-lite-b:green:power";
+ gpios = <&gpio0 9 GPIO_ACTIVE_LOW>;
+ };
+
+ wps {
+ label = "keenetic-lite-b:green:wps";
+ gpios = <&gpio0 14 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ wps {
+ label = "wps";
+ gpios = <&gpio0 0 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_WPS_BUTTON>;
+ };
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 10 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <60000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+ };
+};
+
+&state_default {
+ gpio {
+ groups = "uartf";
+ function = "gpio";
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&esw {
+ mediatek,portmap = <0x2f>;
+ mediatek,led_polarity = <0x17>;
+};
+
+&wmac {
+ ralink,led-polarity = <1>;
+ ralink,mtd-eeprom = <&factory 0x0>;
+};
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 3171646b8a..b75d9078e5 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -1193,6 +1193,15 @@ define Device/zyxel_keenetic
endef
TARGET_DEVICES += zyxel_keenetic
+define Device/zyxel_keenetic-lite-b
+ SOC := rt5350
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := ZyXEL
+ DEVICE_MODEL := Keenetic Lite
+ DEVICE_VARIANT := B
+endef
+TARGET_DEVICES += zyxel_keenetic-lite-b
+
define Device/zyxel_keenetic-start
SOC := rt5350
IMAGE_SIZE := 3776k
diff --git a/target/linux/ramips/rt305x/base-files/etc/board.d/02_network b/target/linux/ramips/rt305x/base-files/etc/board.d/02_network
index f34ade8f68..56c786bc95 100755
--- a/target/linux/ramips/rt305x/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/rt305x/base-files/etc/board.d/02_network
@@ -164,6 +164,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"0:lan" "1:lan" "2:wan" "6@eth0"
;;
+ zyxel,keenetic-lite-b|\
zyxel,keenetic-start)
ucidef_add_switch "switch0" \
"0:lan:3" "1:lan:2" "2:lan:1" "3:lan:0" "4:wan" "6@eth0"