aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2015-10-26 09:18:03 +0000
committerJohn Crispin <blogic@openwrt.org>2015-10-26 09:18:03 +0000
commit58c7c1033fe291ffa73ea016324b94f977858100 (patch)
tree056bf80bc374e9fae4d77f321a3a2faf0368fb82
parenta64b596e72c02cfeaaf3091db1e6d7c0611427d1 (diff)
downloadupstream-58c7c1033fe291ffa73ea016324b94f977858100.tar.gz
upstream-58c7c1033fe291ffa73ea016324b94f977858100.tar.bz2
upstream-58c7c1033fe291ffa73ea016324b94f977858100.zip
bzip2: extend/fix the Host/Install rule to install libbz2.so files
It looks like the bzip2 package does not install any shared libs and has no build rules to install any shared libs. So, for the host build we're installing the libbz2 shared libs manually so that other modules can link against them. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com> Backport of r47245 git-svn-id: svn://svn.openwrt.org/openwrt/branches/chaos_calmer@47269 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/utils/bzip2/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/utils/bzip2/Makefile b/package/utils/bzip2/Makefile
index e1c7b97ffc..ba47cfb7e3 100644
--- a/package/utils/bzip2/Makefile
+++ b/package/utils/bzip2/Makefile
@@ -97,9 +97,10 @@ HOST_CONFIGURE_ARGS+= \
--prefix=$(STAGING_DIR_HOST)
define Host/Install
- $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
+ $(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/ $(STAGING_DIR_HOST)/usr/lib
$(MAKE) -C $(HOST_BUILD_DIR) PREFIX=$(STAGING_DIR_HOST)/usr/ install
-# $(INSTALL_BIN) $(HOST_BUILD_DIR)/Parser/pgen $(STAGING_DIR_HOST)/bin/pgen2
+ $(CP) $(HOST_BUILD_DIR)/libbz2.so* $(STAGING_DIR_HOST)/usr/lib/
+ $(CP) $(HOST_BUILD_DIR)/libbz2.so.1.0 $(STAGING_DIR_HOST)/usr/lib/libbz2.so
endef
$(eval $(call HostBuild))