aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-04-10 18:23:46 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-04-10 19:28:04 +0200
commit60e931eae29ce086fa92d2905c4387f91b069b29 (patch)
treecb9eb5c24b305dbceabb0472b288cf32f2c47689
parent00a85a163405fdf9bee4d8c3f0ee87ca9ed259d6 (diff)
downloadupstream-60e931eae29ce086fa92d2905c4387f91b069b29.tar.gz
upstream-60e931eae29ce086fa92d2905c4387f91b069b29.tar.bz2
upstream-60e931eae29ce086fa92d2905c4387f91b069b29.zip
ath79: consolidate testing kernel
All subtargets have the same testing kernel set, so move it to the target definition. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ath79/Makefile1
-rw-r--r--target/linux/ath79/generic/target.mk2
-rw-r--r--target/linux/ath79/mikrotik/target.mk2
-rw-r--r--target/linux/ath79/nand/target.mk2
-rw-r--r--target/linux/ath79/tiny/target.mk2
5 files changed, 1 insertions, 8 deletions
diff --git a/target/linux/ath79/Makefile b/target/linux/ath79/Makefile
index 288f0f5cd5..4063867ce3 100644
--- a/target/linux/ath79/Makefile
+++ b/target/linux/ath79/Makefile
@@ -9,6 +9,7 @@ SUBTARGETS:=generic mikrotik nand tiny
FEATURES:=ramdisk squashfs usbgadget
KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.10
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/ath79/generic/target.mk b/target/linux/ath79/generic/target.mk
index 2ecaab3f36..4e53c89260 100644
--- a/target/linux/ath79/generic/target.mk
+++ b/target/linux/ath79/generic/target.mk
@@ -2,8 +2,6 @@ BOARDNAME:=Generic
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.10
-
define Target/Description
Build firmware images for generic Atheros AR71xx/AR913x/AR934x based boards.
endef
diff --git a/target/linux/ath79/mikrotik/target.mk b/target/linux/ath79/mikrotik/target.mk
index b98f701fda..f5df904487 100644
--- a/target/linux/ath79/mikrotik/target.mk
+++ b/target/linux/ath79/mikrotik/target.mk
@@ -5,8 +5,6 @@ IMAGES_DIR := ../../..
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.10
-
define Target/Description
Build firmware images for MikroTik devices based on Qualcomm Atheros
MIPS SoCs (AR71xx, AR72xx, AR91xx, AR93xx, QCA95xx).
diff --git a/target/linux/ath79/nand/target.mk b/target/linux/ath79/nand/target.mk
index ed3c381093..7ea9b57f45 100644
--- a/target/linux/ath79/nand/target.mk
+++ b/target/linux/ath79/nand/target.mk
@@ -4,8 +4,6 @@ FEATURES += nand
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.10
-
define Target/Description
Firmware for boards using Qualcomm Atheros, MIPS-based SoCs
in the ar72xx and subsequent series, with support for NAND flash
diff --git a/target/linux/ath79/tiny/target.mk b/target/linux/ath79/tiny/target.mk
index 74b3e966c4..91f135b56e 100644
--- a/target/linux/ath79/tiny/target.mk
+++ b/target/linux/ath79/tiny/target.mk
@@ -3,8 +3,6 @@ FEATURES += small_flash
DEFAULT_PACKAGES += wpad-basic-wolfssl
-KERNEL_TESTING_PATCHVER:=5.10
-
define Target/Description
Build firmware images for Atheros AR71xx/AR913x/AR934x based boards with small flash
endef