aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2019-01-04 21:17:20 +0100
committerChristian Lamparter <chunkeey@gmail.com>2019-01-06 12:26:12 +0100
commit634c733065256979835ca3d7218ae8203a693683 (patch)
tree4f1c1ca95911395dabb60d793b8e11023337de69
parentbbe7ad5a2f0ba298dcc78fc9000cfff25c198a5a (diff)
downloadupstream-634c733065256979835ca3d7218ae8203a693683.tar.gz
upstream-634c733065256979835ca3d7218ae8203a693683.tar.bz2
upstream-634c733065256979835ca3d7218ae8203a693683.zip
ipq40xx: copy Fritz4040 UBoot to STAGING_DIR_IMAGE
Copy U-Boot to STAGING_DIR_IMAGE (and append it to the EVA-image from there) to fix image generation using the image-builder. Also remove the bootloader from DEVICE_PACKAGES and instead use the BUILD_DEVICES directive from within the U-Boot makefile. This fixes eva-image generation using the OpenWRT image-builder. Signed-off-by: David Bauer <mail@david-bauer.net>
-rw-r--r--package/boot/uboot-fritz4040/Makefile8
-rw-r--r--target/linux/ipq40xx/image/Makefile4
2 files changed, 9 insertions, 3 deletions
diff --git a/package/boot/uboot-fritz4040/Makefile b/package/boot/uboot-fritz4040/Makefile
index 3d8c8fb4bb..f48d5d5c13 100644
--- a/package/boot/uboot-fritz4040/Makefile
+++ b/package/boot/uboot-fritz4040/Makefile
@@ -21,11 +21,12 @@ include $(INCLUDE_DIR)/package.mk
define U-Boot/Default
BUILD_TARGET:=ipq40xx
- UBOOT_IMAGE:=uboot-fritz4040.bin
endef
define U-Boot/fritz4040
NAME:=FritzBox 4040
+ UBOOT_IMAGE:=uboot-fritz4040.bin
+ BUILD_DEVICES:=avm_fritzbox-4040
endef
UBOOT_CONFIGURE_VARS += USE_PRIVATE_LIBGCC=yes
@@ -44,6 +45,11 @@ define Build/Compile
(cd $(PKG_BUILD_DIR); ./fritz/fritzcreator.sh;)
endef
+define Build/InstallDev
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+ $(CP) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(UBOOT_IMAGE)
+endef
+
define Package/u-boot/install
$(Package/u-boot/install/default)
$(INSTALL_BIN) $(PKG_BUILD_DIR)/upload-to-f4040.sh $(1)/
diff --git a/target/linux/ipq40xx/image/Makefile b/target/linux/ipq40xx/image/Makefile
index 802d30c4f5..629a5ef48c 100644
--- a/target/linux/ipq40xx/image/Makefile
+++ b/target/linux/ipq40xx/image/Makefile
@@ -82,12 +82,12 @@ define Device/avm_fritzbox-4040
BOARD_NAME := fritz4040
DEVICE_TITLE := AVM Fritz!Box 4040
IMAGE_SIZE := 29753344
- UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+ UBOOT_PATH := $(STAGING_DIR_IMAGE)/uboot-fritz4040.bin
UBOOT_PARTITION_SIZE := 524288
IMAGES = eva.bin sysupgrade.bin
IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
- DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
+ DEVICE_PACKAGES := fritz-tffs fritz-caldata
endef
TARGET_DEVICES += avm_fritzbox-4040