aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-04-13 21:36:58 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-04-13 21:36:58 +0000
commit668fd620805f95d16f8a41eba33317c71ba61f20 (patch)
tree911a094029ddff2180e6da3d138be73f75e0cc22
parente438c665db5e53b8a6f8f0eb4c7dcb6c735e2c78 (diff)
downloadupstream-668fd620805f95d16f8a41eba33317c71ba61f20.tar.gz
upstream-668fd620805f95d16f8a41eba33317c71ba61f20.tar.bz2
upstream-668fd620805f95d16f8a41eba33317c71ba61f20.zip
don't use lzma/jffs2 on <2.6.33, set lzma/jffs2 as default for >=2.6.33. switch verbose mode on compresor statistics.
SVN-Revision: 20844
-rw-r--r--include/image.mk26
-rw-r--r--target/linux/generic-2.6/config-2.6.333
-rw-r--r--target/linux/generic-2.6/config-2.6.343
3 files changed, 24 insertions, 8 deletions
diff --git a/include/image.mk b/include/image.mk
index f2791212bb..34453f460a 100644
--- a/include/image.mk
+++ b/include/image.mk
@@ -18,17 +18,31 @@ KDIR=$(KERNEL_BUILD_DIR)
IMG_PREFIX:=openwrt-$(BOARD)$(if $(SUBTARGET),-$(SUBTARGET))
ifneq ($(CONFIG_BIG_ENDIAN),y)
-JFFS2OPTS := --pad --little-endian --squash
+JFFS2OPTS := --pad --little-endian --squash -v
SQUASHFS_OPTS := -le
else
-JFFS2OPTS := --pad --big-endian --squash
+JFFS2OPTS := --pad --big-endian --squash -v
SQUASHFS_OPTS := -be
endif
-JFFS2OPTS+= $(if $(CONFIG_KERNEL_JFFS2_RTIME)$(LINUX_2_4),-X,-x) rtime
-JFFS2OPTS+= $(if $(CONFIG_KERNEL_JFFS2_ZLIB),-X,-x) zlib
-JFFS2OPTS+= $(if $(CONFIG_KERNEL_JFFS2_LZMA)$(LINUX_2_4),-X,-x) lzma
-JFFS2OPTS+= $(JFFS2COMPR) --compression-mode=size
+ifeq ($(CONFIG_JFFS2_RTIME),y)
+JFFS2OPTS+= -X rtime
+endif
+ifeq ($(CONFIG_JFFS2_ZLIB),y)
+JFFS2OPTS+= -X zlib
+endif
+ifeq ($(CONFIG_JFFS2_LZMA),y)
+JFFS2OPTS+= -X lzma --compression-mode=size
+endif
+ifneq ($(CONFIG_JFFS2_RTIME),y)
+JFFS2OPTS+= -x rtime
+endif
+ifneq ($(CONFIG_JFFS2_ZLIB),y)
+JFFS2OPTS+= -x zlib
+endif
+ifneq ($(CONFIG_JFFS2_LZMA),y)
+JFFS2OPTS+= -x lzma
+endif
ifneq ($(CONFIG_LINUX_2_4)$(CONFIG_LINUX_2_6_25),)
USE_SQUASHFS3 := y
diff --git a/target/linux/generic-2.6/config-2.6.33 b/target/linux/generic-2.6/config-2.6.33
index e154e922f3..ae80b202ac 100644
--- a/target/linux/generic-2.6/config-2.6.33
+++ b/target/linux/generic-2.6/config-2.6.33
@@ -1107,7 +1107,8 @@ CONFIG_JFFS2_FS=y
CONFIG_JFFS2_RTIME=y
# CONFIG_JFFS2_RUBIN is not set
CONFIG_JFFS2_SUMMARY=y
-CONFIG_JFFS2_ZLIB=y
+#CONFIG_JFFS2_ZLIB is not set
+CONFIG_JFFS2_LZMA=y
# CONFIG_JFFS_FS is not set
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_FS is not set
diff --git a/target/linux/generic-2.6/config-2.6.34 b/target/linux/generic-2.6/config-2.6.34
index 836189ded9..53cb190d8e 100644
--- a/target/linux/generic-2.6/config-2.6.34
+++ b/target/linux/generic-2.6/config-2.6.34
@@ -1110,7 +1110,8 @@ CONFIG_JFFS2_FS=y
CONFIG_JFFS2_RTIME=y
# CONFIG_JFFS2_RUBIN is not set
CONFIG_JFFS2_SUMMARY=y
-CONFIG_JFFS2_ZLIB=y
+#CONFIG_JFFS2_ZLIB is not set
+CONFIG_JFFS2_LZMA=y
# CONFIG_JFFS_FS is not set
# CONFIG_JFS_DEBUG is not set
# CONFIG_JFS_FS is not set