aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-05-18 08:32:07 +0000
committerNicolas Thill <nico@openwrt.org>2006-05-18 08:32:07 +0000
commit72fc91e1422c2bf6d4c79eb58e8ad50e381e52fb (patch)
tree337e710d0db80e1efc655f9dabac6f0851578f81
parentba2c5cad003b37ad437ff2b56d14cde80c2cbda6 (diff)
downloadupstream-72fc91e1422c2bf6d4c79eb58e8ad50e381e52fb.tar.gz
upstream-72fc91e1422c2bf6d4c79eb58e8ad50e381e52fb.tar.bz2
upstream-72fc91e1422c2bf6d4c79eb58e8ad50e381e52fb.zip
update busybox to v1.1.3, remove passwd_salt patch (fixed upstream).
SVN-Revision: 3794
-rw-r--r--openwrt/package/busybox/Makefile4
-rw-r--r--openwrt/package/busybox/patches/230-passwd_salt.patch13
2 files changed, 2 insertions, 15 deletions
diff --git a/openwrt/package/busybox/Makefile b/openwrt/package/busybox/Makefile
index 35f954b931..83c74ff4cf 100644
--- a/openwrt/package/busybox/Makefile
+++ b/openwrt/package/busybox/Makefile
@@ -13,11 +13,11 @@ PKG_SOURCE:=$(PKG_NAME)-snapshot.tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads/snapshots
PKG_MD5SUM:=x
else
-PKG_VERSION:=1.1.2
+PKG_VERSION:=1.1.3
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.busybox.net/downloads
-PKG_MD5SUM:=0b5d78072302fe687407956537bdb9e3
+PKG_MD5SUM:=19a0b475169335f17e421cf644616fe7
endif
PKG_CAT:=bzcat
diff --git a/openwrt/package/busybox/patches/230-passwd_salt.patch b/openwrt/package/busybox/patches/230-passwd_salt.patch
deleted file mode 100644
index 0322a98439..0000000000
--- a/openwrt/package/busybox/patches/230-passwd_salt.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- busybox-1.00/loginutils/passwd.c 2006-03-26 06:07:37 -05:00
-+++ busybox-1.00/loginutils/passwd.c 2006-03-26 06:09:03 -05:00
-@@ -386,7 +386,9 @@
- bzero(orig, sizeof(orig));
-
- if (algo == 1) {
-- cp = pw_encrypt(pass, "$1$");
-+ char salt[6]="$1$\0\0\0";
-+ memcpy(salt+3,crypt_make_salt(),3);
-+ cp = pw_encrypt(pass, salt);
- } else
- cp = pw_encrypt(pass, crypt_make_salt());
- bzero(pass, sizeof pass);