aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-29 16:05:40 -0800
committerHauke Mehrtens <hauke@hauke-m.de>2021-03-19 01:25:26 +0100
commit85fa8ad8af6f483a181ed944cc5cfcf9402a3a11 (patch)
tree3a82f88a3587e979ee3146612fc09beb482f092d
parent6e23813c1ed7494a9da3b5e59cfcafd71097c420 (diff)
downloadupstream-85fa8ad8af6f483a181ed944cc5cfcf9402a3a11.tar.gz
upstream-85fa8ad8af6f483a181ed944cc5cfcf9402a3a11.tar.bz2
upstream-85fa8ad8af6f483a181ed944cc5cfcf9402a3a11.zip
kexec-tools: update to 2.0.21
kdump was removed in 7acd257ae67b4ca94f8c23cb8bda0ee0709b9216 gdb can be used as an alternative. Remove autoreconf. It's not needed as the configure files are already generated. Remove upstreamed patch. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--package/boot/kexec-tools/Makefile42
-rw-r--r--package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch14
2 files changed, 3 insertions, 53 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 269345aa9d..36fe53671a 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -8,14 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=kexec-tools
-PKG_VERSION:=2.0.16
-PKG_RELEASE:=2
+PKG_VERSION:=2.0.21
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@KERNEL/linux/utils/kernel/kexec
-PKG_HASH:=5b103351ad752c9badd1d65b00eb6de4bce579f944f4df4e3ef3a755ba567010
-
-PKG_FIXUP:=autoreconf
+PKG_HASH:=e113142dee891638ad96e0f72cf9277b244477619470b30c41999d312e8e8702
PKG_CONFIG_DEPENDS := CONFIG_KEXEC_ZLIB CONFIG_KEXEC_LZMA
@@ -51,17 +49,6 @@ define Package/kexec/description
The kexec utility allows to load and boot another kernel.
endef
-define Package/kdump
- $(call Package/kexec-tools/Default)
- TITLE:=Kernel crash analysis
- DEPENDS:=+kexec @(i386||x86_64||arm) @KERNEL_CRASH_DUMP
-endef
-
-define Package/kdump/description
- The kdump package allows to automatically boot into a
- special kernel for analyzing kernel crashes using kdump.
-endef
-
define Package/kexec/config
source "$(SOURCE)/Config.in"
endef
@@ -108,28 +95,5 @@ define Package/kexec/install
$(LN) ../usr/sbin/kexec $(1)/sbin/kexec
endef
-define Package/kdump/install
- $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config $(1)/etc/uci-defaults
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/kdump $(PKG_INSTALL_DIR)/usr/sbin/vmcore-dmesg $(1)/usr/sbin
- $(INSTALL_BIN) ./files/kdump.init $(1)/etc/init.d/kdump
- $(INSTALL_BIN) ./files/kdump.defaults $(1)/etc/uci-defaults/kdump
- $(INSTALL_CONF) ./files/kdump.config $(1)/etc/config/kdump
-endef
-
-define Package/kdump/prerm
-#!/bin/sh
-
-case $$(uname -m) in
- i?86|x86_64)
- if grep -q " crashkernel=" /boot/grub/grub.cfg; then
- mount /boot -o remount,rw
- sed -i 's/ crashkernel=[^ ]*//' /boot/grub/grub.cfg
- mount /boot -o remount,ro
- fi
- ;;
-esac
-endef
-
$(eval $(call BuildPackage,kexec-tools))
$(eval $(call BuildPackage,kexec))
-$(eval $(call BuildPackage,kdump))
diff --git a/package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch b/package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch
deleted file mode 100644
index dfad21992b..0000000000
--- a/package/boot/kexec-tools/patches/100-kexec-tools-fix-for-Unhandled-rela-relocation-R_X86_64_PLT32-error.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
-index 7fdde73..af33689 100644
---- a/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
-+++ b/kexec/arch/x86_64/kexec-elf-rel-x86_64.c
-@@ -78,7 +78,8 @@ void machine_apply_elf_rel(struct mem_ehdr *UNUSED(ehdr),
- if ((int64_t)value != *(int32_t *)location)
- goto overflow;
- break;
-- case R_X86_64_PC32:
-+ case R_X86_64_PC32:
-+ case R_X86_64_PLT32:
- *(uint32_t *)location = value - address;
- break;
- default: