aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2022-05-16 16:14:41 +0200
committerChristian Lamparter <chunkeey@gmail.com>2022-06-25 00:05:21 +0200
commit8a3fb457223b6a4f68c4ab28162529ae94c6480e (patch)
tree33f3ec253d40769be444b4237b57a06cff4a68fd
parent43fd8f4aba6957148d1e59b245ec4466c7ad3303 (diff)
downloadupstream-8a3fb457223b6a4f68c4ab28162529ae94c6480e.tar.gz
upstream-8a3fb457223b6a4f68c4ab28162529ae94c6480e.tar.bz2
upstream-8a3fb457223b6a4f68c4ab28162529ae94c6480e.zip
netfilter: kmod-nft-xfrm
Add kmod-nft-xfrm package. Signed-off-by: Florian Eckert <fe@dev.tdt.de> (cherry picked from commit 9379bc2fcf905568ef329a121c8c8a11fc98b02c)
-rw-r--r--include/netfilter.mk2
-rw-r--r--package/kernel/linux/modules/netfilter.mk11
2 files changed, 13 insertions, 0 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 20a5a52313..ffe583f657 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -360,6 +360,8 @@ $(eval $(if $(NF_KMOD),$(call nf_add,NFT_TPROXY,CONFIG_NFT_TPROXY, $(P_XT)nft_tp
$(eval $(if $(NF_KMOD),$(call nf_add,NFT_COMPAT,CONFIG_NFT_COMPAT, $(P_XT)nft_compat),))
+$(eval $(if $(NF_KMOD),$(call nf_add,NFT_XFRM,CONFIG_NFT_XFRM, $(P_XT)nft_xfrm),))
+
# userland only
IPT_BUILTIN += $(NF_IPT-y) $(NF_IPT-m)
IPT_BUILTIN += $(IPT_CORE-y) $(IPT_CORE-m)
diff --git a/package/kernel/linux/modules/netfilter.mk b/package/kernel/linux/modules/netfilter.mk
index 1ebe40947a..ff76ae048b 100644
--- a/package/kernel/linux/modules/netfilter.mk
+++ b/package/kernel/linux/modules/netfilter.mk
@@ -1272,3 +1272,14 @@ define KernelPackage/nft-compat
endef
$(eval $(call KernelPackage,nft-compat))
+
+define KernelPackage/nft-xfrm
+ SUBMENU:=$(NF_MENU)
+ TITLE:=Netfilter nf_tables xfrm support (ipsec)
+ DEPENDS:=+kmod-nft-core
+ FILES:=$(foreach mod,$(NFT_XFRM-m),$(LINUX_DIR)/net/$(mod).ko)
+ AUTOLOAD:=$(call AutoProbe,$(notdir $(NFT_XFRM-m)))
+ KCONFIG:=$(KCONFIG_NFT_XFRM)
+endef
+
+$(eval $(call KernelPackage,nft-xfrm))