aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-09-30 17:36:40 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-09-30 17:36:40 +0000
commitb4e9e7ae454e0ed67ce2959b222d998a79303267 (patch)
tree5db76ac7c5e44eed430f97c7ca5a516a3dd1622d
parentf5c53e76ad9d543aaf9005a7fdd88c522108527e (diff)
downloadupstream-b4e9e7ae454e0ed67ce2959b222d998a79303267.tar.gz
upstream-b4e9e7ae454e0ed67ce2959b222d998a79303267.tar.bz2
upstream-b4e9e7ae454e0ed67ce2959b222d998a79303267.zip
forgot the kernel pacthes for the watchdog driver
SVN-Revision: 12816
-rw-r--r--target/linux/ar71xx/patches-2.6.26/006-ar71xx_wdt_driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ar71xx/patches-2.6.26/006-ar71xx_wdt_driver.patch b/target/linux/ar71xx/patches-2.6.26/006-ar71xx_wdt_driver.patch
new file mode 100644
index 0000000000..219dfc0a85
--- /dev/null
+++ b/target/linux/ar71xx/patches-2.6.26/006-ar71xx_wdt_driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -683,6 +683,13 @@
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config AR71XX_WDT
++ tristate "Atheros AR71xx Watchdog Timer"
++ depends on ATHEROS_AR71XX
++ help
++ Hardware driver for the built-in watchdog timer on the Atheros
++ AR71xx SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -97,6 +97,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_AR71XX_WDT) += ar71xx_wdt.o
+
+ # PARISC Architecture
+