aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-10-10 17:04:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-10-10 17:04:17 +0000
commitb806e425a31fc4cf07493e737d526bb0b21463fb (patch)
tree8c3a2da236e211ac0d4401c2127403c9543f616f
parent2122cf17170ced9745c8a1b57d336ce73000bd52 (diff)
downloadupstream-b806e425a31fc4cf07493e737d526bb0b21463fb.tar.gz
upstream-b806e425a31fc4cf07493e737d526bb0b21463fb.tar.bz2
upstream-b806e425a31fc4cf07493e737d526bb0b21463fb.zip
hide .host.mk commands
SVN-Revision: 5023
-rw-r--r--openwrt/include/host.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/openwrt/include/host.mk b/openwrt/include/host.mk
index 6458881472..93f86dce8a 100644
--- a/openwrt/include/host.mk
+++ b/openwrt/include/host.mk
@@ -8,8 +8,8 @@
include $(TOPDIR)/.host.mk
$(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
- echo "HOST_OS:=`uname`" > $@
- echo "HOST_ARCH:=` \
+ @echo "HOST_OS:=`uname`" > $@
+ @echo "HOST_ARCH:=` \
$(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
-e 's/sparc.*/sparc/' \
-e 's/arm.*/arm/' \
@@ -21,8 +21,8 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
-e 's/mipsel-.*/mipsel/' \
-e 's/cris.*/cris/' \
-e 's/i[3-9]86/i386/'`" >> $@
- echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
- if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
+ @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
+ @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
echo "TAR_OPTIONS+=--wildcards" >> $@; \
fi