aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-03-06 14:12:21 +0000
committerNicolas Thill <nico@openwrt.org>2005-03-06 14:12:21 +0000
commitce041c793573b71498f202d89cad41c94f64b8c0 (patch)
tree1abb2e1f25a6b3baa3f8c794ae64bfe4307aaaeb
parent2adfbaaa8d5265bd670ce14c6702c2109f3d9a13 (diff)
downloadupstream-ce041c793573b71498f202d89cad41c94f64b8c0.tar.gz
upstream-ce041c793573b71498f202d89cad41c94f64b8c0.tar.bz2
upstream-ce041c793573b71498f202d89cad41c94f64b8c0.zip
Add missing iptables extensions
SVN-Revision: 318
-rw-r--r--openwrt/package/iptables/kernelconfig.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/openwrt/package/iptables/kernelconfig.mk b/openwrt/package/iptables/kernelconfig.mk
index b04ba54c22..18c8e7540f 100644
--- a/openwrt/package/iptables/kernelconfig.mk
+++ b/openwrt/package/iptables/kernelconfig.mk
@@ -23,6 +23,7 @@ ext-$(CONFIG_IP_NF_MATCH_OWNER) += owner
ext-$(CONFIG_IP_NF_MATCH_PHYSDEV) += physdev
ext-$(CONFIG_IP_NF_TARGET_MASQUERADE) += MASQUERADE
ext-$(CONFIG_IP_NF_TARGET_REDIRECT) += REDIRECT
+ext-$(CONFIG_IP_NF_TARGET_REJECT) += REJECT
ext-$(CONFIG_IP_NF_TARGET_TOS) += TOS
ext-$(CONFIG_IP_NF_TARGET_ECN) += ECN
ext-$(CONFIG_IP_NF_TARGET_DSCP) += DSCP
@@ -31,5 +32,6 @@ ext-$(CONFIG_IP_NF_TARGET_LOG) += LOG
ext-$(CONFIG_IP_NF_TARGET_ULOG) += ULOG
ext-$(CONFIG_IP_NF_TARGET_TCPMSS) += TCPMSS
-
-
+# add extensions that don't depend on kernel config
+ext-m += TTL
+ext-y += icmp standard tcp udp