aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2005-08-14 03:01:53 +0000
committerNicolas Thill <nico@openwrt.org>2005-08-14 03:01:53 +0000
commitd4b4bf9440a21803ede713ee55361f0063df685f (patch)
treedc1435c35f87daef0f506ce832f8f6c73c2b0530
parent7ce0e836b52901b860f453818b5c855bcd2d422a (diff)
downloadupstream-d4b4bf9440a21803ede713ee55361f0063df685f.tar.gz
upstream-d4b4bf9440a21803ede713ee55361f0063df685f.tar.bz2
upstream-d4b4bf9440a21803ede713ee55361f0063df685f.zip
add initial video4linux support (for usb webcams) to head
SVN-Revision: 1654
-rw-r--r--openwrt/target/linux/Config.in7
-rw-r--r--openwrt/target/linux/control/kmod-pwc.control6
-rw-r--r--openwrt/target/linux/control/kmod-videodev.control6
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile6
-rw-r--r--openwrt/target/linux/linux-2.4/config/brcm40
-rw-r--r--openwrt/target/linux/linux-2.4/config/soekris54
6 files changed, 118 insertions, 1 deletions
diff --git a/openwrt/target/linux/Config.in b/openwrt/target/linux/Config.in
index 1fa9050420..891f8f0faa 100644
--- a/openwrt/target/linux/Config.in
+++ b/openwrt/target/linux/Config.in
@@ -324,6 +324,13 @@ config BR2_PACKAGE_KMOD_SCHED
help
Kernel schedulers for IP traffic
+config BR2_PACKAGE_KMOD_VIDEODEV
+ tristate "Video (For Linux) kernel support"
+ default m
+
+config BR2_PACKAGE_KMOD_PWC
+ tristate "Kernel driver for USB Philips Cameras"
+ default m
config BR2_PACKAGE_KMOD_NATSEMI
tristate "Soekris net4801 ethernet driver"
diff --git a/openwrt/target/linux/control/kmod-pwc.control b/openwrt/target/linux/control/kmod-pwc.control
new file mode 100644
index 0000000000..ecd5485b44
--- /dev/null
+++ b/openwrt/target/linux/control/kmod-pwc.control
@@ -0,0 +1,6 @@
+Package: kmod-pwc
+Priority: optional
+Section: sys
+Maintainer: Nicolas Thill <nico@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/target/linux/linux-2.4/
+Description: Kernel driver for USB Philips Cameras
diff --git a/openwrt/target/linux/control/kmod-videodev.control b/openwrt/target/linux/control/kmod-videodev.control
new file mode 100644
index 0000000000..c8526835c4
--- /dev/null
+++ b/openwrt/target/linux/control/kmod-videodev.control
@@ -0,0 +1,6 @@
+Package: kmod-videodev
+Priority: optional
+Section: sys
+Maintainer: Nicolas Thill <nico@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/target/linux/linux-2.4/
+Description: Video For Linux kernel support
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index ff3cbb6e13..0fcf441a88 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -171,6 +171,12 @@ $(eval $(call KMOD_template,GRE,gre,\
$(eval $(call KMOD_template,SCHED,sched,\
$(MODULES_DIR)/kernel/net/sched/*.o \
))
+$(eval $(call KMOD_template,VIDEODEV,videodev,\
+ $(MODULES_DIR)/kernel/drivers/media/video/videodev.o \
+))
+$(eval $(call KMOD_template,PWC,pwc,\
+ $(MODULES_DIR)/kernel/drivers/usb/pwc.o \
+))
$(TARGETS): $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/linux-2.4/config/brcm b/openwrt/target/linux/linux-2.4/config/brcm
index 6ed41112e5..f8e50d76fc 100644
--- a/openwrt/target/linux/linux-2.4/config/brcm
+++ b/openwrt/target/linux/linux-2.4/config/brcm
@@ -1072,7 +1072,35 @@ CONFIG_NLS_DEFAULT="iso8859-1"
#
# Multimedia devices
#
-# CONFIG_VIDEO_DEV is not set
+CONFIG_VIDEO_DEV=m
+
+#
+# Video For Linux
+#
+CONFIG_VIDEO_PROC_FS=y
+# CONFIG_I2C_PARPORT is not set
+# CONFIG_VIDEO_BT848 is not set
+# CONFIG_VIDEO_PMS is not set
+# CONFIG_VIDEO_BWQCAM is not set
+# CONFIG_VIDEO_CQCAM is not set
+# CONFIG_VIDEO_CPIA is not set
+# CONFIG_VIDEO_SAA5249 is not set
+# CONFIG_TUNER_3036 is not set
+# CONFIG_VIDEO_STRADIS is not set
+# CONFIG_VIDEO_ZORAN is not set
+# CONFIG_VIDEO_ZORAN_BUZ is not set
+# CONFIG_VIDEO_ZORAN_DC10 is not set
+# CONFIG_VIDEO_ZORAN_LML33 is not set
+# CONFIG_VIDEO_ZR36120 is not set
+# CONFIG_VIDEO_MEYE is not set
+
+#
+# Radio Adapters
+#
+# CONFIG_RADIO_GEMTEK_PCI is not set
+# CONFIG_RADIO_MAXIRADIO is not set
+# CONFIG_RADIO_MAESTRO is not set
+# CONFIG_RADIO_MIROPCM20 is not set
#
# Sound
@@ -1119,6 +1147,16 @@ CONFIG_USB_PRINTER=m
# CONFIG_USB_SCANNER is not set
# CONFIG_USB_MICROTEK is not set
# CONFIG_USB_HPUSBSCSI is not set
+# CONFIG_USB_IBMCAM is not set
+# CONFIG_USB_KONICAWC is not set
+# CONFIG_USB_OV511 is not set
+CONFIG_USB_PWC=m
+# CONFIG_USB_SE401 is not set
+# CONFIG_USB_STV680 is not set
+# CONFIG_USB_W9968CF is not set
+# CONFIG_USB_VICAM is not set
+# CONFIG_USB_DSBR is not set
+# CONFIG_USB_DABUSB is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
# CONFIG_USB_KAWETH is not set
diff --git a/openwrt/target/linux/linux-2.4/config/soekris b/openwrt/target/linux/linux-2.4/config/soekris
index aa987110b2..4fdb6a2be0 100644
--- a/openwrt/target/linux/linux-2.4/config/soekris
+++ b/openwrt/target/linux/linux-2.4/config/soekris
@@ -1045,6 +1045,50 @@ CONFIG_NLS_DEFAULT="iso8859-1"
# CONFIG_NLS_UTF8 is not set
#
+# Multimedia devices
+#
+CONFIG_VIDEO_DEV=m
+
+#
+# Video For Linux
+#
+CONFIG_VIDEO_PROC_FS=y
+# CONFIG_I2C_PARPORT is not set
+# CONFIG_VIDEO_BT848 is not set
+# CONFIG_VIDEO_PMS is not set
+# CONFIG_VIDEO_BWQCAM is not set
+# CONFIG_VIDEO_CQCAM is not set
+# CONFIG_VIDEO_CPIA is not set
+# CONFIG_VIDEO_SAA5249 is not set
+# CONFIG_TUNER_3036 is not set
+# CONFIG_VIDEO_STRADIS is not set
+# CONFIG_VIDEO_ZORAN is not set
+# CONFIG_VIDEO_ZORAN_BUZ is not set
+# CONFIG_VIDEO_ZORAN_DC10 is not set
+# CONFIG_VIDEO_ZORAN_LML33 is not set
+# CONFIG_VIDEO_ZR36120 is not set
+# CONFIG_VIDEO_MEYE is not set
+
+#
+# Radio Adapters
+#
+# CONFIG_RADIO_CADET is not set
+# CONFIG_RADIO_RTRACK is not set
+# CONFIG_RADIO_RTRACK2 is not set
+# CONFIG_RADIO_AZTECH is not set
+# CONFIG_RADIO_GEMTEK is not set
+# CONFIG_RADIO_GEMTEK_PCI is not set
+# CONFIG_RADIO_MAXIRADIO is not set
+# CONFIG_RADIO_MAESTRO is not set
+# CONFIG_RADIO_MIROPCM20 is not set
+# CONFIG_RADIO_SF16FMI is not set
+# CONFIG_RADIO_SF16FMR2 is not set
+# CONFIG_RADIO_TERRATEC is not set
+# CONFIG_RADIO_TRUST is not set
+# CONFIG_RADIO_TYPHOON is not set
+# CONFIG_RADIO_ZOLTRIX is not set
+
+#
# Sound
#
# CONFIG_SOUND is not set
@@ -1091,6 +1135,16 @@ CONFIG_USB_PRINTER=m
# CONFIG_USB_SCANNER is not set
# CONFIG_USB_MICROTEK is not set
# CONFIG_USB_HPUSBSCSI is not set
+# CONFIG_USB_IBMCAM is not set
+# CONFIG_USB_KONICAWC is not set
+# CONFIG_USB_OV511 is not set
+CONFIG_USB_PWC=m
+# CONFIG_USB_SE401 is not set
+# CONFIG_USB_STV680 is not set
+# CONFIG_USB_W9968CF is not set
+# CONFIG_USB_VICAM is not set
+# CONFIG_USB_DSBR is not set
+# CONFIG_USB_DABUSB is not set
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
# CONFIG_USB_KAWETH is not set