aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2017-09-25 06:00:51 +0300
committerStijn Tintel <stijn@linux-ipv6.be>2017-09-25 07:42:34 +0300
commitd9beae9b9e172920a262a97cdf5f5279789b5f7f (patch)
tree11d6e5a375c5f727a15f56caddc007cc3aa53128
parent2ad649d134ff85b478aa0962aaf86bf9efd52ce6 (diff)
downloadupstream-d9beae9b9e172920a262a97cdf5f5279789b5f7f.tar.gz
upstream-d9beae9b9e172920a262a97cdf5f5279789b5f7f.tar.bz2
upstream-d9beae9b9e172920a262a97cdf5f5279789b5f7f.zip
curl: bump to 7.55.1
Update 200-no_docs_tests.patch. Refresh patches. Fixes the following CVEs: - CVE-2017-1000099 - CVE-2017-1000100 - CVE-2017-1000101 Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
-rw-r--r--package/network/utils/curl/Makefile4
-rw-r--r--package/network/utils/curl/patches/200-no_docs_tests.patch16
-rw-r--r--package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch2
3 files changed, 11 insertions, 11 deletions
diff --git a/package/network/utils/curl/Makefile b/package/network/utils/curl/Makefile
index 9a59a66a8e..330d8d518c 100644
--- a/package/network/utils/curl/Makefile
+++ b/package/network/utils/curl/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
-PKG_VERSION:=7.54.1
+PKG_VERSION:=7.55.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -16,7 +16,7 @@ PKG_SOURCE_URL:=https://dl.uxnr.de/mirror/curl/ \
http://curl.mirror.anstey.ca/ \
http://curl.askapache.com/download/ \
https://curl.haxx.se/download/
-PKG_HASH:=fdfc4df2d001ee0c44ec071186e770046249263c491fcae48df0e1a3ca8f25a0
+PKG_HASH:=e5b1a92ed3b0c11f149886458fa063419500819f1610c020d62f25b8e4b16cfb
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
diff --git a/package/network/utils/curl/patches/200-no_docs_tests.patch b/package/network/utils/curl/patches/200-no_docs_tests.patch
index f5a158bf9c..9ef4819d41 100644
--- a/package/network/utils/curl/patches/200-no_docs_tests.patch
+++ b/package/network/utils/curl/patches/200-no_docs_tests.patch
@@ -1,22 +1,22 @@
--- a/Makefile.am
+++ b/Makefile.am
-@@ -154,8 +154,8 @@
-
+@@ -155,7 +155,7 @@ CLEANFILES = $(VC6_LIBDSP) $(VC6_SRCDSP)
bin_SCRIPTS = curl-config
--SUBDIRS = lib docs src include
--DIST_SUBDIRS = $(SUBDIRS) tests packages scripts
-+SUBDIRS = lib src include
-+DIST_SUBDIRS = $(SUBDIRS) packages
+ SUBDIRS = lib src
+-DIST_SUBDIRS = $(SUBDIRS) tests packages scripts include docs
++DIST_SUBDIRS = $(SUBDIRS) packages include
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libcurl.pc
-@@ -275,7 +275,7 @@
+@@ -275,8 +275,8 @@ cygwinbin:
# We extend the standard install with a custom hook:
install-data-hook:
cd include && $(MAKE) install
- cd docs && $(MAKE) install
-+# cd docs && $(MAKE) install
+- cd docs/libcurl && $(MAKE) install
++ #cd docs && $(MAKE) install
++ #cd docs/libcurl && $(MAKE) install
# We extend the standard uninstall with a custom hook:
uninstall-hook:
diff --git a/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch b/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch
index ef9c4b8070..52b017c9bf 100644
--- a/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch
+++ b/package/network/utils/curl/patches/310-mbedtls-disable-runtime-version-check.patch
@@ -1,6 +1,6 @@
--- a/lib/vtls/mbedtls.c
+++ b/lib/vtls/mbedtls.c
-@@ -796,7 +796,7 @@
+@@ -796,7 +796,7 @@ void Curl_mbedtls_session_free(void *ptr
size_t Curl_mbedtls_version(char *buffer, size_t size)
{