aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2020-08-05 01:04:59 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-08 16:13:51 +0200
commitde78747de111ba5e4c978fe8067b2260efe01d0d (patch)
tree59efff0b785de7575d78bf38098e2c13252e5861
parenta40ddc2195350149aadbdb6077b17d4787becd9d (diff)
downloadupstream-de78747de111ba5e4c978fe8067b2260efe01d0d.tar.gz
upstream-de78747de111ba5e4c978fe8067b2260efe01d0d.tar.bz2
upstream-de78747de111ba5e4c978fe8067b2260efe01d0d.zip
ramips: use lzma-loader for RT5350F-OLinuXino devices
The bootloader fails to extract a big kernel, e.g. v5.4 kernel image with ALL_KMODS enabled. This can be fixed by using lzma-loader. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
-rw-r--r--target/linux/ramips/image/rt305x.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index b75d9078e5..2cda2fa51b 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -767,6 +767,7 @@ endef
TARGET_DEVICES += nixcore_x1-8m
define Device/olimex_rt5350f-olinuxino
+ $(Device/uimage-lzma-loader)
SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := OLIMEX
@@ -777,6 +778,7 @@ endef
TARGET_DEVICES += olimex_rt5350f-olinuxino
define Device/olimex_rt5350f-olinuxino-evb
+ $(Device/uimage-lzma-loader)
SOC := rt5350
IMAGE_SIZE := 7872k
DEVICE_VENDOR := OLIMEX