aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYanase Yuki <dev@zpc.sakura.ne.jp>2020-02-06 12:00:47 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-12 00:43:09 +0200
commite66becb490796d0787f8bd2448ee6f14198a904a (patch)
treedbb4f28b4824cbd9b77f83619169163b81f39486
parent7b1d809a8d8620032553845cf4a8819a19508687 (diff)
downloadupstream-e66becb490796d0787f8bd2448ee6f14198a904a.tar.gz
upstream-e66becb490796d0787f8bd2448ee6f14198a904a.tar.bz2
upstream-e66becb490796d0787f8bd2448ee6f14198a904a.zip
ramips: add support for I-O DATA WN-AX2033GR
I-O DATA WN-AX2033GR is roughly the same as I-O DATA WN-AX1167GR2. The difference is Wi-Fi feature. Specification ============= - SoC: MediaTek MT7621A - RAM: DDR3 128 MiB - Flash Memory: NAND 128 MiB (Spansion S34ML01G200TF100) - Wi-Fi: MediaTek MT7603E - Wi-Fi: MediaTek MT7615 - Ethernet: 5x 10 Mbps / 100 Mbps / 1000 Mbps (1x WAN, 4x LAN) - LED: 2x green LED - Input: 2x tactile switch, 1x slide switch - Serial console: 57600bps, PCB through hole J5 (Vcc, TX, RX, NC, GND) - Power: DC 12V This device only supports channel 1-13 and 36-140. Thus, narrower frequency limits compared to other devices are required for limiting wi-fi frequency correctly. Without this, non-supported frequencies are activated. Flash instructions ================== 1. Open the router management page (192.168.0.1). 2. Update router firmware using "initramfs-kernel.bin". 3. After updating, run sysupgrade with "sysupgrade.bin". Recovery instructions ===================== WN-AX2033GR contains Zyxel Z-LOADER 1. Setup TFTP server (IP address: 10.10.10.3). 2. Put official firmware into TFTP server directory (distribution site: https://www.iodata.jp/lib/software/w/2068.htm) 3. Connect WX-AX2033GR Ethernet port and computer that runs TFTP server. 4. Connect to serial console. 5. Interrupt booting by Esc key. 6. Flash firmware using "ATNR 1,[firmware filename]" command. Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp> [adjust for kernel 5.4, add recovery instructions/frequency comment] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
-rw-r--r--target/linux/ramips/dts/mt7621_iodata_wn-ax2033gr.dts37
-rw-r--r--target/linux/ramips/image/mt7621.mk16
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh1
3 files changed, 54 insertions, 0 deletions
diff --git a/target/linux/ramips/dts/mt7621_iodata_wn-ax2033gr.dts b/target/linux/ramips/dts/mt7621_iodata_wn-ax2033gr.dts
new file mode 100644
index 0000000000..39f72e375a
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_iodata_wn-ax2033gr.dts
@@ -0,0 +1,37 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621_iodata_wn-xx-xr.dtsi"
+
+/ {
+ compatible = "iodata,wn-ax2033gr", "mediatek,mt7621-soc";
+ model = "I-O DATA WN-AX2033GR";
+};
+
+&partitions {
+ partition@6b00000 {
+ label = "Backup";
+ reg = <0x6b00000 0x1480000>;
+ read-only;
+ };
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+
+ mediatek,mtd-eeprom = <&factory 0x0>;
+ ieee80211-freq-limit = <2400000 2483000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 5710000>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index ec9d8aacae..6b2e68b03b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -381,6 +381,22 @@ define Device/iodata_wn-ax1167gr2
endef
TARGET_DEVICES += iodata_wn-ax1167gr2
+define Device/iodata_wn-ax2033gr
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ UBINIZE_OPTS := -E 5
+ UIMAGE_MAGIC := 0x434f4d42
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 51200k
+ DEVICE_VENDOR := I-O DATA
+ DEVICE_MODEL := WN-AX2033GR
+ KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(VST.1)C10 | \
+ iodata-mstc-header
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += iodata_wn-ax2033gr
+
define Device/iodata_wn-dx1167r
BLOCKSIZE := 128k
PAGESIZE := 2048
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index afb3a52a82..3f292a5dac 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -57,6 +57,7 @@ platform_do_upgrade() {
nand_do_upgrade "$1"
;;
iodata,wn-ax1167gr2|\
+ iodata,wn-ax2033gr|\
iodata,wn-dx1167r)
iodata_mstc_upgrade_prepare
nand_do_upgrade "$1"