aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-09-27 14:53:54 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-09-27 14:53:54 +0000
commitef54e937124c72ecf877426684a670070e170746 (patch)
tree58e349a2f70d95c02d23d25736493f2bc3f62b08
parent142fb3e229a33f0988c7aa61f0e3713700de30f5 (diff)
downloadupstream-ef54e937124c72ecf877426684a670070e170746.tar.gz
upstream-ef54e937124c72ecf877426684a670070e170746.tar.bz2
upstream-ef54e937124c72ecf877426684a670070e170746.zip
ar71xx: build firmware image for the TL-WR841N v7
SVN-Revision: 23134
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile5
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index 6e55772b3d..bad8744751 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -60,6 +60,17 @@ endef
$(eval $(call Profile,TLWR841NDV5))
+define Profile/TLWR841NDV7
+ NAME:=TP-LINK TL-WR841ND v7
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR841NDV7/Description
+ Package set optimized for the TP-LINK TL-WR841ND v7.
+endef
+
+$(eval $(call Profile,TLWR841NDV7))
+
define Profile/TLWR941NDV2
NAME:=TP-LINK TL-WR941ND v2
PACKAGES:=kmod-ath9k wpad-mini
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3fa49ba36e..0c348565ff 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -551,6 +551,10 @@ define Image/Build/Profile/TLWR841NDV5
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr841nd-v5,board=TL-WR741ND,TL-WR841NDv5)
endef
+define Image/Build/Profile/TLWR841NDV7
+ $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr841nd-v7,board=TL-WR741ND,TL-WR841NDv7)
+endef
+
define Image/Build/Profile/TLWR941NDV2
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr941nd-v2,board=TL-WR941ND,TL-WR941NDv2)
endef
@@ -620,6 +624,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLWR841NV15,$(1))
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))
+ $(call Image/Build/Profile/TLWR841NDV7,$(1))
$(call Image/Build/Profile/TLWR941NDV2,$(1))
$(call Image/Build/Profile/TLWR941NDV3,$(1))
$(call Image/Build/Profile/TLWR941NDV4,$(1))