aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-02-28 07:30:13 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-02-28 07:30:13 +0000
commitf9ffa3755795f84904d370a8dcc7ef390842c282 (patch)
tree067d89e588689d17dc053804c4b4ea264d59d943
parentc1eb7f7ce95a7a9c4e73499eea4aa803556f960f (diff)
downloadupstream-f9ffa3755795f84904d370a8dcc7ef390842c282.tar.gz
upstream-f9ffa3755795f84904d370a8dcc7ef390842c282.tar.bz2
upstream-f9ffa3755795f84904d370a8dcc7ef390842c282.zip
Added ctorrent, statically compiled for the moment (need uClibc++ fixes)
SVN-Revision: 3282
-rw-r--r--openwrt/package/ctorrent/Config.in10
-rwxr-xr-xopenwrt/package/ctorrent/Makefile50
-rw-r--r--openwrt/package/ctorrent/ipkg/ctorrent.control4
3 files changed, 64 insertions, 0 deletions
diff --git a/openwrt/package/ctorrent/Config.in b/openwrt/package/ctorrent/Config.in
new file mode 100644
index 0000000000..7295ace04f
--- /dev/null
+++ b/openwrt/package/ctorrent/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_CTORRENT
+ prompt "ctorrent.......................... console-based BitTorrent client"
+ tristate
+ default m if CONFIG_DEVEL
+ help
+ CTorrent is a BitTorrent client written in the C programming language, known to
+ be a very robust and mature programming language, which produces fast and
+ optimized application.
+
+ http://www.rahul.net/dholmes/ctorrent/
diff --git a/openwrt/package/ctorrent/Makefile b/openwrt/package/ctorrent/Makefile
new file mode 100755
index 0000000000..b723a33bdc
--- /dev/null
+++ b/openwrt/package/ctorrent/Makefile
@@ -0,0 +1,50 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ctorrent
+PKG_VERSION:=1.3.4-dnh2
+PKG_RELEASE:=1
+PKG_MD5SUM:=6635e2d0d0ee21faeb85d95cd93c137b
+
+PKG_SOURCE_URL:=http://www.rahul.net/dholmes/ctorrent/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-dnh2
+PKG_CAT:=zcat
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,CTORRENT,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+ $(TARGET_CONFIGURE_OPTS) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/openssl" \
+ LDFLAGS="-static -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ ./configure \
+ --target=$(GNU_TARGET_NAME) \
+ --host=$(GNU_TARGET_NAME) \
+ --build=$(GNU_HOST_NAME) \
+ --prefix=/usr \
+ --exec-prefix=/usr \
+ --bindir=/usr/bin \
+ --sbindir=/usr/sbin \
+ --libexecdir=/usr/lib \
+ --sysconfdir=/etc \
+ --datadir=/usr/share \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --program-prefix="" \
+ --with-gnu-ld \
+ );
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ $(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+
+$(IPKG_CTORRENT):
+ mkdir -p $(IDIR_CTORRENT)
+ $(CP) $(PKG_INSTALL_DIR)/* $(IDIR_CTORRENT)/
+ $(RSTRIP) $(IDIR_CTORRENT)/
+ $(IPKG_BUILD) $(IDIR_CTORRENT) $(PACKAGE_DIR)
diff --git a/openwrt/package/ctorrent/ipkg/ctorrent.control b/openwrt/package/ctorrent/ipkg/ctorrent.control
new file mode 100644
index 0000000000..0b7d1d59ed
--- /dev/null
+++ b/openwrt/package/ctorrent/ipkg/ctorrent.control
@@ -0,0 +1,4 @@
+Package: ctorrent
+Priority: optional
+Section: net
+Description: console-based BitTorrent client