aboutsummaryrefslogtreecommitdiffstats
path: root/docs/Makefile
diff options
context:
space:
mode:
authorAlberto Bursi <alberto.bursi@outlook.it>2016-11-28 20:28:12 +0100
committerJohn Crispin <john@phrozen.org>2016-11-29 21:12:08 +0100
commit882f4d2d63272abce8c1966983aa10178e2e971f (patch)
tree68687b152130405452a1ad9b930ff2971378834c /docs/Makefile
parentc0e66478b520b07c33343161f722351f5f858990 (diff)
downloadupstream-882f4d2d63272abce8c1966983aa10178e2e971f.tar.gz
upstream-882f4d2d63272abce8c1966983aa10178e2e971f.tar.bz2
upstream-882f4d2d63272abce8c1966983aa10178e2e971f.zip
docs: deleting docs because they are obsolete
the docs in /docs folder are pretty much obsolete and in a not very friendly format (latex, that requires to be compiled), leaving them there only causes confusion. LEDE documentation's place is the wiki, or the site. Signed-off-by: Alberto Bursi <alberto.bursi@outlook.it>
Diffstat (limited to 'docs/Makefile')
-rw-r--r--docs/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/docs/Makefile b/docs/Makefile
deleted file mode 100644
index c113d62571..0000000000
--- a/docs/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-ifeq ($(TOPDIR),)
- TOPDIR:=${CURDIR}/..
-endif
-PKG_NAME=docs
-
-all: compile
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/prereq.mk
-
-MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex debugging.tex $(TMP_DIR)/.prereq-docs
-
-compile: $(TMP_DIR)/.prereq-docs
- $(NO_TRACE_MAKE) cleanup
- latex $(MAIN)
- $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
- $(NO_TRACE_MAKE) cleanup
-
-$(TMP_DIR)/.prereq-docs:
- mkdir -p $(TMP_DIR)
- $(NO_TRACE_MAKE) prereq
- touch $@
-
-openwrt.html: $(DEPS)
- htlatex $(MAIN)
-
-openwrt.pdf: $(DEPS)
- pdflatex $(MAIN)
-
-clean: cleanup
- rm -f openwrt.pdf openwrt.html openwrt.css
-
-cleanup: FORCE
- rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
-
-$(eval $(call RequireCommand,latex, \
- You need to install LaTeX to build the OpenWrt documentation \
-))
-$(eval $(call RequireCommand,pdflatex, \
- You need to install PDFLaTeX to build the OpenWrt documentation \
-))
-$(eval $(call RequireCommand,htlatex, \
- You need to install tex4ht to build the OpenWrt documentation \
-))
-
-FORCE:
-.PHONY: FORCE