aboutsummaryrefslogtreecommitdiffstats
path: root/include/package.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-09-28 01:23:56 +0000
commit800ef0f56ca5971811267b5639c7895c2d569491 (patch)
tree4223d1f8eb3174463a4f20bc90c8e68d6eb13b19 /include/package.mk
parentbb402acf616778e36b0d0b24c71167407875fea5 (diff)
downloadupstream-800ef0f56ca5971811267b5639c7895c2d569491.tar.gz
upstream-800ef0f56ca5971811267b5639c7895c2d569491.tar.bz2
upstream-800ef0f56ca5971811267b5639c7895c2d569491.zip
some minor fixes, cleanups, package build abstraction
SVN-Revision: 9051
Diffstat (limited to 'include/package.mk')
-rw-r--r--include/package.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/include/package.mk b/include/package.mk
index 43d0663f60..9090455658 100644
--- a/include/package.mk
+++ b/include/package.mk
@@ -97,8 +97,15 @@ endif
$(call shexport,Package/$(1)/description)
$(call shexport,Package/$(1)/config)
- $(Dumpinfo)
- $(BuildIPKG)
+ $(if $(DUMP), \
+ $(Dumpinfo), \
+ $(foreach target, \
+ $(if $(Package/$(1)/targets),$(Package/$(1)/targets), \
+ $(if $(PKG_TARGETS),$(PKG_TARGETS), ipkg ) \
+ ), $(BuildTarget/$(target)) \
+ ) \
+ )
+ $(if $(DUMP),,$(call Build/DefaultTargets,$(1)))
endef
# prevent libtool from setting rpath when linking