aboutsummaryrefslogtreecommitdiffstats
path: root/include/target.mk
diff options
context:
space:
mode:
authorRalph Hempel <ralph.hempel@lantiq.com>2009-02-20 10:32:45 +0000
committerRalph Hempel <ralph.hempel@lantiq.com>2009-02-20 10:32:45 +0000
commit3d0285a783851da63b0e17ad251ee2add9322408 (patch)
tree19233341c2545ac770e5ea873475f70ae10b5b3b /include/target.mk
parent6e590d85f3bc8b263a1a3c15149ef2384fe9fd0b (diff)
downloadupstream-3d0285a783851da63b0e17ad251ee2add9322408.tar.gz
upstream-3d0285a783851da63b0e17ad251ee2add9322408.tar.bz2
upstream-3d0285a783851da63b0e17ad251ee2add9322408.zip
avoid kernel version in target if sub-targets available (usefull if we have 2.4 and 2.6 sub-targets in parallel)
SVN-Revision: 14576
Diffstat (limited to 'include/target.mk')
-rw-r--r--include/target.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/include/target.mk b/include/target.mk
index 7351794dce..ee373aa19e 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -154,7 +154,7 @@ define BuildTargets/DumpCurrent
@echo 'Target: $(TARGETID)'; \
echo 'Target-Board: $(BOARD)'; \
echo 'Target-Kernel: $(KERNEL)'; \
- echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGET),, [$(KERNEL)])'; \
+ echo 'Target-Name: $(BOARDNAME)$(if $(SUBTARGETS),, [$(KERNEL)])$(if $(SUBTARGETS),$(if $(SUBTARGET), [$(KERNEL)]))'; \
echo 'Target-Path: $(subst $(TOPDIR)/,,$(PWD))'; \
echo 'Target-Arch: $(ARCH)'; \
echo 'Target-Features: $(FEATURES)'; \