aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorRobert Marko <robert.marko@sartura.hr>2020-03-18 19:39:43 +0100
committerAlexander Couzens <lynxis@fe80.eu>2020-03-23 02:12:30 +0100
commit835d1c68a0f036c8b0d837a48b5a05fdfb2e8218 (patch)
tree36425e921e01545d77d5940a1c250bced40a89cd /include
parent8a92ae8e4b30370cca37e2498fe2ccb4340fa101 (diff)
downloadupstream-835d1c68a0f036c8b0d837a48b5a05fdfb2e8218.tar.gz
upstream-835d1c68a0f036c8b0d837a48b5a05fdfb2e8218.tar.bz2
upstream-835d1c68a0f036c8b0d837a48b5a05fdfb2e8218.zip
build: add GCC 10 version detection
Lets add GCC 10 detection to the build system as distributions like Fedora 32 have started shipping with it. Some tools like mtd-utils need work to compile under GCC10, but that will be next step. Signed-off-by: Robert Marko <robert.marko@sartura.hr>
Diffstat (limited to 'include')
-rw-r--r--include/prereq-build.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/include/prereq-build.mk b/include/prereq-build.mk
index 19904853f1..156b3f3722 100644
--- a/include/prereq-build.mk
+++ b/include/prereq-build.mk
@@ -28,8 +28,8 @@ $(eval $(call TestHostCommand,proper-umask, \
$(eval $(call SetupHostCommand,gcc, \
Please install the GNU C Compiler (gcc) 4.8 or later, \
- $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
- gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+ $(CC) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+ gcc -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
gcc48 --version | grep gcc, \
gcc49 --version | grep gcc, \
gcc5 --version | grep gcc, \
@@ -37,6 +37,7 @@ $(eval $(call SetupHostCommand,gcc, \
gcc7 --version | grep gcc, \
gcc8 --version | grep gcc, \
gcc9 --version | grep gcc, \
+ gcc10 --version | grep gcc, \
gcc --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-gcc, \
@@ -47,8 +48,8 @@ $(eval $(call TestHostCommand,working-gcc, \
$(eval $(call SetupHostCommand,g++, \
Please install the GNU C++ Compiler (g++) 4.8 or later, \
- $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
- g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?)', \
+ $(CXX) -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
+ g++ -dumpversion | grep -E '^(4\.[8-9]|[5-9]\.?|10\.?)', \
g++48 --version | grep g++, \
g++49 --version | grep g++, \
g++5 --version | grep g++, \
@@ -56,6 +57,7 @@ $(eval $(call SetupHostCommand,g++, \
g++7 --version | grep g++, \
g++8 --version | grep g++, \
g++9 --version | grep g++, \
+ g++10 --version | grep g++, \
g++ --version | grep -E 'Apple.(LLVM|clang)' ))
$(eval $(call TestHostCommand,working-g++, \