aboutsummaryrefslogtreecommitdiffstats
path: root/include
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-03 08:58:14 +0000
commit8dc7ced4d4df85bc6cc77b625d54150a64f31bc6 (patch)
treee506b1895f22ee50f8e03e6806afc8384560e78a /include
parente5e03321f9e942f75b8b150dc0bbdaba6b1c0c9b (diff)
downloadupstream-8dc7ced4d4df85bc6cc77b625d54150a64f31bc6.tar.gz
upstream-8dc7ced4d4df85bc6cc77b625d54150a64f31bc6.tar.bz2
upstream-8dc7ced4d4df85bc6cc77b625d54150a64f31bc6.zip
require all CONFIG_* symbols listed in its KCONFIG to be set to m in order to actually build a kmod package, tweak and fix kernel package definitions.
SVN-Revision: 8591
Diffstat (limited to 'include')
-rw-r--r--include/kernel.mk3
-rw-r--r--include/netfilter.mk13
2 files changed, 10 insertions, 6 deletions
diff --git a/include/kernel.mk b/include/kernel.mk
index 519ea42d23..a0f256b998 100644
--- a/include/kernel.mk
+++ b/include/kernel.mk
@@ -104,7 +104,8 @@ $(call KernelPackage/$(1)/description)
endef
endif
- ifneq ($(if $(KCONFIG),$(filter m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$($(c)))),.),)
+ # check that all CONFIG_* symbols in $(KCONFIG) are set to 'm'
+ ifeq ($(filter-out m,$(foreach c,$(filter-out %=y %=n %=m,$(KCONFIG)),$(if $($(c)),$($(c)),n))),)
ifneq ($(strip $(FILES)),)
define Package/kmod-$(1)/install
mkdir -p $$(1)/lib/modules/$(LINUX_VERSION)
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 49ffefbad6..f11deacbd1 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -12,17 +12,20 @@ P_XT:=netfilter/
endif
define nf_add
-$(1)-$$($(2)) += $(3)
-KCONFIG_$(1) += $(2)
+ $(1)-$$($(2)) += $(3)
+ ifeq ($$($(2)),m)
+ KCONFIG_$(1) += $(2)
+ endif
endef
+
IPT_CONNTRACK-m :=
-$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNMARK, $(P_V4)ipt_connmark))
-$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
-$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNTRACK, $(P_V4)ipt_conntrack))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_HELPER, $(P_V4)ipt_helper))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_STATE, $(P_V4)ipt_state))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNMARK, $(P_V4)ipt_connmark))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_CONNMARK, $(P_XT)xt_connmark))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_TARGET_CONNMARK, $(P_V4)ipt_CONNMARK))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_TARGET_CONNMARK, $(P_XT)xt_CONNMARK))
+$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_IP_NF_MATCH_CONNTRACK, $(P_V4)ipt_conntrack))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_CONNTRACK, $(P_XT)xt_conntrack))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_HELPER, $(P_XT)xt_helper))
$(eval $(call nf_add,IPT_CONNTRACK,CONFIG_NETFILTER_XT_MATCH_STATE, $(P_XT)xt_state))