aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt/target/linux
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-05-18 00:35:02 +0000
committerNicolas Thill <nico@openwrt.org>2006-05-18 00:35:02 +0000
commitba2c5cad003b37ad437ff2b56d14cde80c2cbda6 (patch)
tree3fecf56282f5d9342326a5d7c042333425cca907 /openwrt/target/linux
parent71877a42eb364644f0bd59520c86d9a7d7e60e8b (diff)
downloadupstream-ba2c5cad003b37ad437ff2b56d14cde80c2cbda6.tar.gz
upstream-ba2c5cad003b37ad437ff2b56d14cde80c2cbda6.tar.bz2
upstream-ba2c5cad003b37ad437ff2b56d14cde80c2cbda6.zip
load kernel modules in kmod- packages from postinst scripts at install.
SVN-Revision: 3793
Diffstat (limited to 'openwrt/target/linux')
-rw-r--r--openwrt/target/linux/rules.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/openwrt/target/linux/rules.mk b/openwrt/target/linux/rules.mk
index 3358f1fd93..ae557f26b4 100644
--- a/openwrt/target/linux/rules.mk
+++ b/openwrt/target/linux/rules.mk
@@ -76,6 +76,11 @@ ifneq ($(6),)
for module in $(7); do \
echo $$$$module >> $$(I_$(1))/etc/modules.d/$(6)-$(2); \
done
+ echo "#!/bin/sh" >> $$(I_$(1))/CONTROL/postinst
+ echo "[ -z \"\$$$$IPKG_INSTROOT\" ] || exit" >> $$(I_$(1))/CONTROL/postinst
+ echo ". /etc/functions.sh" >> $$(I_$(1))/CONTROL/postinst
+ echo "load_modules /etc/modules.d/$(6)-$(2)" >> $$(I_$(1))/CONTROL/postinst
+ chmod 0755 $$(I_$(1))/CONTROL/postinst
endif
$(8)
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR) $(MAKE_TRACE)