aboutsummaryrefslogtreecommitdiffstats
path: root/openwrt
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2006-06-03 16:23:17 +0000
committerNicolas Thill <nico@openwrt.org>2006-06-03 16:23:17 +0000
commit3f3deee507e6ff8ecb996e343f59682ccb701117 (patch)
treeace2ac8a41c11da56210e0292cac2dee46b7cb45 /openwrt
parent11fdda8fce5c21680051197e0cc51efc484cafff (diff)
downloadupstream-3f3deee507e6ff8ecb996e343f59682ccb701117.tar.gz
upstream-3f3deee507e6ff8ecb996e343f59682ccb701117.tar.bz2
upstream-3f3deee507e6ff8ecb996e343f59682ccb701117.zip
add aircrack-ng package (thanks to Gerd, closes: #572, #581).
SVN-Revision: 3900
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/Config.in1
-rw-r--r--openwrt/package/Makefile1
-rw-r--r--openwrt/package/aircrack-ng/Config.in13
-rw-r--r--openwrt/package/aircrack-ng/Makefile48
-rw-r--r--openwrt/package/aircrack-ng/ipkg/aircrack-ng.control5
5 files changed, 68 insertions, 0 deletions
diff --git a/openwrt/package/Config.in b/openwrt/package/Config.in
index 6621882918..b443bc2fcb 100644
--- a/openwrt/package/Config.in
+++ b/openwrt/package/Config.in
@@ -61,6 +61,7 @@ endmenu
menu "Networking"
source "package/aircrack/Config.in"
+source "package/aircrack-ng/Config.in"
source "package/amwall/Config.in"
source "package/arpd/Config.in"
source "package/arptables/Config.in"
diff --git a/openwrt/package/Makefile b/openwrt/package/Makefile
index b22ba17aa1..e5b226932a 100644
--- a/openwrt/package/Makefile
+++ b/openwrt/package/Makefile
@@ -5,6 +5,7 @@ include $(TOPDIR)/package/depend.mk
package-$(BR2_PACKAGE_6TUNNEL) += 6tunnel
package-$(BR2_PACKAGE_AICCU) += aiccu
package-$(BR2_PACKAGE_AIRCRACK) += aircrack
+package-$(BR2_PACKAGE_AIRCRACK_NG) += aircrack-ng
package-$(BR2_PACKAGE_AMWALL) += amwall
package-$(BR2_PACKAGE_ARPD) += arpd
package-$(BR2_PACKAGE_ARPTABLES) += arptables
diff --git a/openwrt/package/aircrack-ng/Config.in b/openwrt/package/aircrack-ng/Config.in
new file mode 100644
index 0000000000..1c019c3330
--- /dev/null
+++ b/openwrt/package/aircrack-ng/Config.in
@@ -0,0 +1,13 @@
+config BR2_PACKAGE_AIRCRACK_NG
+ prompt "aircrack-ng....................... Next generation of aircrack with new features"
+ tristate
+ default n
+ help
+ aircrack-ng is an 802.11 WEP and WPA-PSK keys cracking program
+ that can recover this keys once enough encrypted packets have
+ been captured. It implements the standard FMS attack along with
+ some optimizations like KoreK attacks, thus making the attack
+ much faster compared to other WEP cracking tools. In fact
+ aircrack is a set of tools for auditing wireless networks.
+
+ http://www.aircrack-ng.org/
diff --git a/openwrt/package/aircrack-ng/Makefile b/openwrt/package/aircrack-ng/Makefile
new file mode 100644
index 0000000000..afbb0eed12
--- /dev/null
+++ b/openwrt/package/aircrack-ng/Makefile
@@ -0,0 +1,48 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=aircrack-ng
+PKG_VERSION:=0.5
+PKG_RELEASE:=1
+PKG_MD5SUM:=303daa6f1b030f8f9a2f00542051b96c
+
+PKG_SOURCE_URL:=http://download.aircrack-ng.org
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,AIRCRACK_NG,aircrack-ng,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+ touch $@
+
+$(PKG_BUILD_DIR)/.built:
+ rm -rf $(PKG_INSTALL_DIR)
+ mkdir -p $(PKG_INSTALL_DIR)
+ $(MAKE) -C $(PKG_BUILD_DIR) \
+ CC="$(TARGET_CC)" \
+ CFLAGS="$(TARGET_CFLAGS) -Wall" \
+ prefix="/usr" \
+ destdir="$(PKG_INSTALL_DIR)" \
+ all install
+ touch $@
+
+$(IPKG_AIRCRACK_NG):
+ install -d -m0755 $(IDIR_AIRCRACK_NG)/usr/bin
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/aircrack-ng $(IDIR_AIRCRACK_NG)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/airdecap-ng $(IDIR_AIRCRACK_NG)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/arpforge-ng $(IDIR_AIRCRACK_NG)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/ivstools $(IDIR_AIRCRACK_NG)/usr/bin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/kstats $(IDIR_AIRCRACK_NG)/usr/bin/
+ install -d -m0755 $(IDIR_AIRCRACK_NG)/usr/sbin
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/aireplay-ng $(IDIR_AIRCRACK_NG)/usr/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airodump-ng $(IDIR_AIRCRACK_NG)/usr/sbin/
+ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/airmon-ng $(IDIR_AIRCRACK_NG)/usr/sbin/
+ $(RSTRIP) $(IDIR_AIRCRACK_NG)
+ $(IPKG_BUILD) $(IDIR_AIRCRACK_NG) $(PACKAGE_DIR)
+
diff --git a/openwrt/package/aircrack-ng/ipkg/aircrack-ng.control b/openwrt/package/aircrack-ng/ipkg/aircrack-ng.control
new file mode 100644
index 0000000000..cff7a5fecd
--- /dev/null
+++ b/openwrt/package/aircrack-ng/ipkg/aircrack-ng.control
@@ -0,0 +1,5 @@
+Package: aircrack-ng
+Priority: optional
+Section: net
+Depends:
+Description: Aircrack-ng - the next generation of aircrack with new features