aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-08 21:33:53 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-08 21:33:53 +0000
commit656412d1a3806d94b280a9955df528faad6aa8e9 (patch)
tree012a0788f3f546b5540756e0ee6a57aa223319b7 /package/base-files/Makefile
parentcd10aa726f1803513f172fff4c194a3cdcb868a3 (diff)
downloadupstream-656412d1a3806d94b280a9955df528faad6aa8e9.tar.gz
upstream-656412d1a3806d94b280a9955df528faad6aa8e9.tar.bz2
upstream-656412d1a3806d94b280a9955df528faad6aa8e9.zip
Forward port whiterussian resolv.conf changes /etc/resolv.conf links to /tmp/resolv.conf /tmp/resolv.conf links to /tmp/resolv.conf.auto by default (which is where the ISPs nameserver is in) When dnsmasq starts, it replaces /tmp/resolv.conf with a file pointing to 127.0.0.1
SVN-Revision: 6043
Diffstat (limited to 'package/base-files/Makefile')
-rw-r--r--package/base-files/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index 16c6dc1eb8..14917f683b 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -115,6 +115,7 @@ define Package/base-files$(TARGET)/install
rm -f $(1)/var
ln -sf /tmp $(1)/var
mkdir -p $(1)/etc
+ ln -sf /tmp/resolv.conf $(1)/etc/resolv.conf
$(call Package/base-files/install-target,$(1))
for conffile in $(1)/etc/config/*; do \
if [ -f "$$$$conffile" ]; then \