aboutsummaryrefslogtreecommitdiffstats
path: root/package/base-files
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2009-09-16 14:21:19 +0000
committerJo-Philipp Wich <jow@openwrt.org>2009-09-16 14:21:19 +0000
commit2f921cb48d47a3aeb7e33773b6b0de0a71b36947 (patch)
tree354caa0ff3e9696f41bc56c553a431ce612e0a67 /package/base-files
parentdd88fdee3300289e581e9adf3bee6e3e5bccc4cf (diff)
downloadupstream-2f921cb48d47a3aeb7e33773b6b0de0a71b36947.tar.gz
upstream-2f921cb48d47a3aeb7e33773b6b0de0a71b36947.tar.bz2
upstream-2f921cb48d47a3aeb7e33773b6b0de0a71b36947.zip
base-files: clear ip addresses on interfaces that are about to be added to a bridge
SVN-Revision: 17596
Diffstat (limited to 'package/base-files')
-rw-r--r--package/base-files/Makefile2
-rwxr-xr-xpackage/base-files/files/lib/network/config.sh2
2 files changed, 3 insertions, 1 deletions
diff --git a/package/base-files/Makefile b/package/base-files/Makefile
index d87253b4dd..6995601a28 100644
--- a/package/base-files/Makefile
+++ b/package/base-files/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=base-files
-PKG_RELEASE:=30
+PKG_RELEASE:=31
PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
diff --git a/package/base-files/files/lib/network/config.sh b/package/base-files/files/lib/network/config.sh
index bfadf40c89..fbbf0e119b 100755
--- a/package/base-files/files/lib/network/config.sh
+++ b/package/base-files/files/lib/network/config.sh
@@ -123,6 +123,7 @@ prepare_interface() {
append newdevs "$dev"
done
uci_set_state network "$config" device "$newdevs"
+ $DEBUG ifconfig "$iface" 0.0.0.0
$DEBUG brctl addif "br-$config" "$iface"
# Bridge existed already. No further processing necesary
} || {
@@ -131,6 +132,7 @@ prepare_interface() {
$DEBUG brctl addbr "br-$config"
$DEBUG brctl setfd "br-$config" 0
$DEBUG ifconfig "br-$config" up
+ $DEBUG ifconfig "$iface" 0.0.0.0
$DEBUG brctl addif "br-$config" "$iface"
$DEBUG brctl stp "br-$config" $stp
# Creating the bridge here will have triggered a hotplug event, which will