aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/kexec-tools/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-28 11:27:16 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-28 11:27:16 +0000
commit512a3c5d8141b8431b0242f5d98ec2e7dd7d445a (patch)
tree1ddc74b5fb6e96c2a89e5dabde00c65d89dea44a /package/boot/kexec-tools/Makefile
parentea5f9a7ba7e43df2a0b44a58003b85c501a5ca5f (diff)
downloadupstream-512a3c5d8141b8431b0242f5d98ec2e7dd7d445a.tar.gz
upstream-512a3c5d8141b8431b0242f5d98ec2e7dd7d445a.tar.bz2
upstream-512a3c5d8141b8431b0242f5d98ec2e7dd7d445a.zip
kexec-tools: reduce size
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 37072
Diffstat (limited to 'package/boot/kexec-tools/Makefile')
-rw-r--r--package/boot/kexec-tools/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/boot/kexec-tools/Makefile b/package/boot/kexec-tools/Makefile
index 541dca275a..40ba9eb525 100644
--- a/package/boot/kexec-tools/Makefile
+++ b/package/boot/kexec-tools/Makefile
@@ -56,6 +56,9 @@ CONFIGURE_ARGS = \
--sysconfdir=/etc \
$(if $(CONFIG_KEXEC_ZLIB),--with,--without)-zlib
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections
+
CONFIGURE_VARS += \
BUILD_CC="$(HOSTCC)" \
TARGET_CC="$(TARGET_CC)"