aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/tfa-layerscape/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-07-30 13:12:43 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-19 15:29:46 +0100
commit80dcd14abeed8cd808b92bb307964dbaeb252144 (patch)
tree93e33a02dfdfd0f01775309afa1cbbde6200c321 /package/boot/tfa-layerscape/Makefile
parentf59d7aab2a374d27abfdc50348d855db5560db8f (diff)
downloadupstream-80dcd14abeed8cd808b92bb307964dbaeb252144.tar.gz
upstream-80dcd14abeed8cd808b92bb307964dbaeb252144.tar.bz2
upstream-80dcd14abeed8cd808b92bb307964dbaeb252144.zip
layerscape: add LX2160ARDB (Rev2.0 silicon) board support
The QorIQ LX2160A reference design board provides a comprehensive platform that enables design and evaluation of the LX2160A processor. - Enables network intelligence with the next generation Datapath (DPPA2) which provides differentiated offload and a rich set of IO, including 10GE, 25GE, 40GE, and PCIe Gen4 - Delivers unprecedented efficiency and new virtualized networks - Supports designs in 5G packet processing, network function virtualization, storage controller, white box switching, network interface cards, and mobile edge computing - Supports all three LX2 family members (16-core LX2160A; 12-core LX2120A; and 8-core LX2080A) Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> [use AUTORELEASE, add dtb to firmware part] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/boot/tfa-layerscape/Makefile')
-rw-r--r--package/boot/tfa-layerscape/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/package/boot/tfa-layerscape/Makefile b/package/boot/tfa-layerscape/Makefile
index c0efd3ad9e..d5a1664278 100644
--- a/package/boot/tfa-layerscape/Makefile
+++ b/package/boot/tfa-layerscape/Makefile
@@ -123,6 +123,20 @@ define Package/tfa-ls2088a-rdb
BOOT_MODE:=nor
endef
+define Package/tfa-lx2160a-rdb
+ $(Package/tfa-generic)
+ TITLE:=NXP LX2160ARDB Trusted Firmware
+ PLAT:=lx2160ardb
+ BOOT_MODE:=flexspi_nor
+endef
+
+define Package/tfa-lx2160a-rdb-sdboot
+ $(Package/tfa-generic)
+ TITLE:=NXP LX2160ARDB SD Boot Trusted Firmware
+ PLAT:=lx2160ardb
+ BOOT_MODE:=sd
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/build/$(PLAT)/release/bl2_$(BOOT_MODE).pbl \
@@ -154,7 +168,9 @@ TFAS := \
ls1046a-rdb-sdboot \
ls1088a-rdb \
ls1088a-rdb-sdboot \
- ls2088a-rdb
+ ls2088a-rdb \
+ lx2160a-rdb \
+ lx2160a-rdb-sdboot
$(eval $(call HostBuild))
$(foreach tfa,$(TFAS), \