aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-at91
diff options
context:
space:
mode:
authorSandeep Sheriker M <sandeep.sheriker@microchip.com>2020-08-22 12:55:49 -0700
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-25 19:28:42 +0200
commitabf6c288c1434c4f7b946c48cc8d91ddab94958e (patch)
treeaae834cf52bb5fc7734af1881dcd97a33eaca5a9 /package/boot/uboot-at91
parent9b36ca80322a77a9938f28ba5d618f37d42dd903 (diff)
downloadupstream-abf6c288c1434c4f7b946c48cc8d91ddab94958e.tar.gz
upstream-abf6c288c1434c4f7b946c48cc8d91ddab94958e.tar.bz2
upstream-abf6c288c1434c4f7b946c48cc8d91ddab94958e.zip
uboot-at91: bump version to linux4sam-2020.04
Bump version to linux4sam-2020.04 and add patch to fix Wformat-security warnings. Signed-off-by: Sandeep Sheriker M <sandeep.sheriker@microchip.com>
Diffstat (limited to 'package/boot/uboot-at91')
-rw-r--r--package/boot/uboot-at91/Makefile4
-rw-r--r--package/boot/uboot-at91/patches/001-fix-Wformat-security.patch34
2 files changed, 32 insertions, 6 deletions
diff --git a/package/boot/uboot-at91/Makefile b/package/boot/uboot-at91/Makefile
index 547b72f8d9..1fb32d4a89 100644
--- a/package/boot/uboot-at91/Makefile
+++ b/package/boot/uboot-at91/Makefile
@@ -7,12 +7,12 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=linux4sam_6.0
+PKG_VERSION:=linux4sam-2020.04
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/linux4sam/u-boot-at91.git
-PKG_SOURCE_VERSION:=1e7d2e5973c1fb780e55e28a801c6c574158ac14
+PKG_SOURCE_VERSION:=0e1d1b6efb7f8e27c372279a906fcd2524df09da
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
diff --git a/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch b/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
index 18f9af742c..23cb5828b3 100644
--- a/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
+++ b/package/boot/uboot-at91/patches/001-fix-Wformat-security.patch
@@ -1,13 +1,39 @@
diff --git a/cmd/version.c b/cmd/version.c
-index b2fffe9..bcbbeb1 100644
+index b2fffe99..bcbbeb18 100644
--- a/cmd/version.c
+++ b/cmd/version.c
@@ -18,7 +18,7 @@ static int do_version(cmd_tbl_t *cmdtp, int flag, int argc, char * const argv[])
{
- char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
-
+ char buf[DISPLAY_OPTIONS_BANNER_LENGTH];
+
- printf(display_options_get_banner(false, buf, sizeof(buf)));
+ printf("%s",display_options_get_banner(false, buf, sizeof(buf)));
#ifdef CC_VERSION_STRING
- puts(CC_VERSION_STRING "\n");
+ puts(CC_VERSION_STRING "\n");
#endif
+diff --git a/drivers/pinctrl/pinctrl-uclass.c b/drivers/pinctrl/pinctrl-uclass.c
+index 3425ed11..8c2e1d5c 100644
+--- a/drivers/pinctrl/pinctrl-uclass.c
++++ b/drivers/pinctrl/pinctrl-uclass.c
+@@ -368,7 +368,7 @@ int pinctrl_get_pin_name(struct udevice *dev, int selector, char *buf,
+ if (!ops->get_pin_name)
+ return -ENOSYS;
+
+- snprintf(buf, size, ops->get_pin_name(dev, selector));
++ snprintf(buf, size, "%s", ops->get_pin_name(dev, selector));
+
+ return 0;
+ }
+diff --git a/lib/efi_loader/efi_variable.c b/lib/efi_loader/efi_variable.c
+index c316bdfe..5fe8129c 100644
+--- a/lib/efi_loader/efi_variable.c
++++ b/lib/efi_loader/efi_variable.c
+@@ -522,7 +522,7 @@ efi_status_t EFIAPI efi_set_variable(u16 *variable_name,
+
+ if (old_size)
+ /* APPEND_WRITE */
+- s += sprintf(s, old_val);
++ s += sprintf(s, "%s", old_val);
+ else
+ s += sprintf(s, "(blob)");
+