aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-imx6/Makefile
diff options
context:
space:
mode:
authorVladimir Vid <vladimir.vid@sartura.hr>2018-04-26 17:52:14 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2018-07-07 18:33:57 +0200
commit856cc6d9998ea717ee25d80bef52635dceeae71a (patch)
treeda678b9719acbe5ada3efe8dc4b21b3c1507c56e /package/boot/uboot-imx6/Makefile
parent87493dac11f3c7bbbc1fed9aef1cf9ff62053ab0 (diff)
downloadupstream-856cc6d9998ea717ee25d80bef52635dceeae71a.tar.gz
upstream-856cc6d9998ea717ee25d80bef52635dceeae71a.tar.bz2
upstream-856cc6d9998ea717ee25d80bef52635dceeae71a.zip
uboot-imx: bump to 2018.03 which fixes the build issues with fdt64_t redefinitions
* change mx6qsabresd to mx6qsabres to match defconfig name * merge wanboard profiles since there is only one defconfig for the target device * move wanboard options from wandboard.h to defconfig * remove legacy patches Signed-off-by: Vladimir Vid <vladimir.vid@sartura.hr>
Diffstat (limited to 'package/boot/uboot-imx6/Makefile')
-rw-r--r--package/boot/uboot-imx6/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/package/boot/uboot-imx6/Makefile b/package/boot/uboot-imx6/Makefile
index 8d422758dd..613a5338ef 100644
--- a/package/boot/uboot-imx6/Makefile
+++ b/package/boot/uboot-imx6/Makefile
@@ -7,10 +7,10 @@
include $(TOPDIR)/rules.mk
-PKG_VERSION:=2014.04
+PKG_VERSION:=2018.03
PKG_RELEASE:=1
-PKG_HASH:=7b6444bd23eb61068c43bd1d44ec7e7bfdbce5cadeca20c833eee186b4d3fd31
+PKG_HASH:=7e7477534409d5368eb1371ffde6820f0f79780a1a1f676161c48442cb303dfd
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
@@ -20,7 +20,7 @@ define U-Boot/Default
UBOOT_IMAGE:=u-boot.imx
endef
-define U-Boot/mx6qsabresd
+define U-Boot/mx6sabresd
NAME:=SABRE i.MX6Quad board
endef
@@ -48,31 +48,21 @@ define U-Boot/nitrogen6s1g
NAME:=Nitrogen6x i.MX6Solo 1GB board
endef
-define U-Boot/wandboard_dl
- NAME:=Wandboard Dual Lite
- BUILD_DEVICES:=wandboard
-endef
-
-define U-Boot/wandboard_quad
- NAME:=Wandboard Quad
- BUILD_DEVICES:=wandboard
-endef
-
-define U-Boot/wandboard_solo
- NAME:=Wandboard Solo
+define U-Boot/wandboard
+ NAME:=Wandboard Dual Lite/Quad/Solo
BUILD_DEVICES:=wandboard
endef
UBOOT_TARGETS := \
- mx6qsabresd \
+ mx6sabresd \
nitrogen6dl \
nitrogen6dl2g \
nitrogen6q \
nitrogen6q2g \
nitrogen6s \
nitrogen6s1g \
- wandboard_dl \
- wandboard_quad \
- wandboard_solo
+ wandboard
+
+UBOOT_MAKE_FLAGS += u-boot.imx
$(eval $(call BuildPackage/U-Boot))