aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-layerscape/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2020-08-03 12:52:22 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-02-19 15:27:15 +0100
commit2c2d77bd3bd4691c5f8f1760b9ef16f96f345255 (patch)
tree4327185141cbed9f6a30fada4e6dafad3ac15ddb /package/boot/uboot-layerscape/Makefile
parenta9075d42d7990af230a08bdbb03c14ae2bf27318 (diff)
downloadupstream-2c2d77bd3bd4691c5f8f1760b9ef16f96f345255.tar.gz
upstream-2c2d77bd3bd4691c5f8f1760b9ef16f96f345255.tar.bz2
upstream-2c2d77bd3bd4691c5f8f1760b9ef16f96f345255.zip
layerscape: add FRWY-LS1046A board support
The LS1046A Freeway board (FRWY) is a high-performance computing, evaluation, and development platform that supports the QorIQ LS1046A architecture processor capable of support more than 32,000 CoreMark performance. The FRWY-LS1046A board supports the QorIQ LS1046A processor, onboard DDR4 memory, multiple Gigabit Ethernet, USB3.0 and M2_Type_E interfaces for Wi-Fi. The FRWY-LS1046A-TP includes the Coral Tensor Flow Processing Unit that offloads AI/ML inferencing from the CPU to provide significant boost for AI/ML applications. The FRWY-LS1046A-TP includes one M.2 TPU module and more modules can easily be added including USB versions of the module to scale the AI/ML performance. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com> [rebase, use AUTORELEASE, fix sorting, add dtb to firmware part] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/boot/uboot-layerscape/Makefile')
-rw-r--r--package/boot/uboot-layerscape/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index ec1b45d70f..98b129f0ff 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-layerscape
PKG_VERSION:=LSDK-20.04-update-290520
-PKG_RELEASE:=2
+PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://source.codeaurora.org/external/qoriq/qoriq-components/u-boot
@@ -55,6 +55,16 @@ define U-Boot/fsl_ls1043a-rdb-sdboot
UBOOT_CONFIG:=ls1043ardb_tfa
endef
+define U-Boot/fsl_ls1046a-frwy
+ NAME:=NXP LS1046AFRWY
+ UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
+define U-Boot/fsl_ls1046a-frwy-sdboot
+ NAME:=NXP LS1046AFRWY SD Card Boot
+ UBOOT_CONFIG:=ls1046afrwy_tfa
+endef
+
define U-Boot/fsl_ls1046a-rdb
NAME:=NXP LS1046ARDB
UBOOT_CONFIG:=ls1046ardb_tfa
@@ -109,6 +119,8 @@ UBOOT_TARGETS := \
fsl_ls1012a-frwy-sdboot \
fsl_ls1043a-rdb \
fsl_ls1043a-rdb-sdboot \
+ fsl_ls1046a-frwy \
+ fsl_ls1046a-frwy-sdboot \
fsl_ls1046a-rdb \
fsl_ls1046a-rdb-sdboot \
fsl_ls1088a-rdb \