aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2022-07-13 11:28:07 +0100
committerDaniel Golle <daniel@makrotopia.org>2022-07-13 11:38:57 +0100
commite0e74d8a2ced19f46428d30efd388db72d79326b (patch)
tree5a5d2cd08d70f7cb1430f9f446886107675492b7 /package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch
parent7659ee1e2786ccc78656362d7007e4c402c939b7 (diff)
downloadupstream-e0e74d8a2ced19f46428d30efd388db72d79326b.tar.gz
upstream-e0e74d8a2ced19f46428d30efd388db72d79326b.tar.bz2
upstream-e0e74d8a2ced19f46428d30efd388db72d79326b.zip
uboot-mediatek: unbreak build with binman
swig has been installed on the buildbots a while a ago and Petr Štetiar got a fix for the pylibfdt error. Use that and re-enable the builds for mt7620 and mt7621. Refresh patches while at it. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch')
-rw-r--r--package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch b/package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch
new file mode 100644
index 0000000000..89d3c82475
--- /dev/null
+++ b/package/boot/uboot-mediatek/patches/300-force-pylibfdt-build.patch
@@ -0,0 +1,30 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2063,26 +2063,7 @@ endif
+ # Check dtc and pylibfdt, if DTC is provided, else build them
+ PHONY += scripts_dtc
+ scripts_dtc: scripts_basic
+- $(Q)if test "$(DTC)" = "$(DTC_INTREE)"; then \
+- $(MAKE) $(build)=scripts/dtc; \
+- else \
+- if ! $(DTC) -v >/dev/null; then \
+- echo '*** Failed to check dtc version: $(DTC)'; \
+- false; \
+- else \
+- if test "$(call dtc-version)" -lt $(DTC_MIN_VERSION); then \
+- echo '*** Your dtc is too old, please upgrade to dtc $(DTC_MIN_VERSION) or newer'; \
+- false; \
+- else \
+- if [ -n "$(CONFIG_PYLIBFDT)" ]; then \
+- if ! echo "import libfdt" | $(PYTHON3) 2>/dev/null; then \
+- echo '*** pylibfdt does not seem to be available with $(PYTHON3)'; \
+- false; \
+- fi; \
+- fi; \
+- fi; \
+- fi; \
+- fi
++ $(MAKE) $(build)=scripts/dtc
+
+ # ---------------------------------------------------------------------------
+ quiet_cmd_cpp_lds = LDS $@