aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-mvebu/patches
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2020-08-19 17:54:58 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2020-09-18 21:42:05 +0200
commitae2e521b34ca3504e7f32898dcd7e1c71707d206 (patch)
tree1686698ffcd2bf13b70d61aa7fcb0aff1573adb0 /package/boot/uboot-mvebu/patches
parent5582fbd6135f7db4ba8bd887c360007f3b18dba1 (diff)
downloadupstream-ae2e521b34ca3504e7f32898dcd7e1c71707d206.tar.gz
upstream-ae2e521b34ca3504e7f32898dcd7e1c71707d206.tar.bz2
upstream-ae2e521b34ca3504e7f32898dcd7e1c71707d206.zip
uboot-mvebu: update to v2020.10-rc4
TODO: switch to release v2020.10 once released. Remove one merged patch, refresh the rest. Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/uboot-mvebu/patches')
-rw-r--r--package/boot/uboot-mvebu/patches/100-add_support_for_macronix_mx25u12835f.patch4
-rw-r--r--package/boot/uboot-mvebu/patches/120-mvebu_armada-37xx.h_increase_max_gunzip_size.patch2
-rw-r--r--package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch8
-rw-r--r--package/boot/uboot-mvebu/patches/220-arm-dts-uDPU-switch-default-PHY-speed-to-3.125Gbit.patch43
4 files changed, 7 insertions, 50 deletions
diff --git a/package/boot/uboot-mvebu/patches/100-add_support_for_macronix_mx25u12835f.patch b/package/boot/uboot-mvebu/patches/100-add_support_for_macronix_mx25u12835f.patch
index 79b1b66e76..f1a292694d 100644
--- a/package/boot/uboot-mvebu/patches/100-add_support_for_macronix_mx25u12835f.patch
+++ b/package/boot/uboot-mvebu/patches/100-add_support_for_macronix_mx25u12835f.patch
@@ -1,7 +1,7 @@
--- a/drivers/mtd/spi/spi-nor-ids.c
+++ b/drivers/mtd/spi/spi-nor-ids.c
-@@ -136,6 +136,7 @@ const struct flash_info spi_nor_ids[] =
- { INFO("mx25u1635e", 0xc22535, 0, 64 * 1024, 32, SECT_4K) },
+@@ -151,6 +151,7 @@ const struct flash_info spi_nor_ids[] =
+ { INFO("mx25u3235f", 0xc22536, 0, 4 * 1024, 1024, SECT_4K) },
{ INFO("mx25u6435f", 0xc22537, 0, 64 * 1024, 128, SECT_4K) },
{ INFO("mx25l12805d", 0xc22018, 0, 64 * 1024, 256, 0) },
+ { INFO("mx25u12835f", 0xc22538, 0, 64 * 1024, 256, SECT_4K) },
diff --git a/package/boot/uboot-mvebu/patches/120-mvebu_armada-37xx.h_increase_max_gunzip_size.patch b/package/boot/uboot-mvebu/patches/120-mvebu_armada-37xx.h_increase_max_gunzip_size.patch
index 580270a70f..c543e5126a 100644
--- a/package/boot/uboot-mvebu/patches/120-mvebu_armada-37xx.h_increase_max_gunzip_size.patch
+++ b/package/boot/uboot-mvebu/patches/120-mvebu_armada-37xx.h_increase_max_gunzip_size.patch
@@ -9,5 +9,5 @@ This is required in order to boot itb images.
#define CONFIG_SYS_SDRAM_BASE 0x00000000
+#define CONFIG_SYS_BOOTM_LEN (64 << 20) /* Increase max gunzip size */
- #define CONFIG_NR_DRAM_BANKS 1
+ /* auto boot */
diff --git a/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch b/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch
index ee6c73f469..eb0b05e4c6 100644
--- a/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch
+++ b/package/boot/uboot-mvebu/patches/210-link-libcrypto-static.patch
@@ -3,10 +3,10 @@ needed dependencies are added too.
--- a/tools/Makefile
+++ b/tools/Makefile
-@@ -145,7 +145,7 @@ endif
- # MXSImage needs LibSSL
- ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CONFIG_ARMADA_38X)$(CONFIG_ARMADA_39X)$(CONFIG_FIT_SIGNATURE),)
- HOSTLOADLIBES_mkimage += \
+@@ -158,7 +158,7 @@ ifneq ($(CONFIG_MX23)$(CONFIG_MX28)$(CON
+ HOSTCFLAGS_kwbimage.o += \
+ $(shell pkg-config --cflags libssl libcrypto 2> /dev/null || echo "")
+ HOSTLDLIBS_mkimage += \
- $(shell pkg-config --libs libssl libcrypto 2> /dev/null || echo "-lssl -lcrypto")
+ $(shell pkg-config --libs --static libssl libcrypto 2> /dev/null || echo "-lssl -lpthread -lcrypto")
diff --git a/package/boot/uboot-mvebu/patches/220-arm-dts-uDPU-switch-default-PHY-speed-to-3.125Gbit.patch b/package/boot/uboot-mvebu/patches/220-arm-dts-uDPU-switch-default-PHY-speed-to-3.125Gbit.patch
deleted file mode 100644
index 0e10b2c767..0000000000
--- a/package/boot/uboot-mvebu/patches/220-arm-dts-uDPU-switch-default-PHY-speed-to-3.125Gbit.patch
+++ /dev/null
@@ -1,43 +0,0 @@
---- a/arch/arm/dts/armada-3720-uDPU.dts
-+++ b/arch/arm/dts/armada-3720-uDPU.dts
-@@ -109,11 +109,11 @@
- &comphy {
- phy0 {
- phy-type = <PHY_TYPE_SGMII1>;
-- phy-speed = <PHY_SPEED_1_25G>;
-+ phy-speed = <PHY_SPEED_3_125G>;
- };
- phy1 {
- phy-type = <PHY_TYPE_SGMII0>;
-- phy-speed = <PHY_SPEED_1_25G>;
-+ phy-speed = <PHY_SPEED_3_125G>;
- };
-
- phy2 {
-@@ -125,22 +125,16 @@
- &eth0 {
- pinctrl-0 = <&pcie_pins>;
- status = "okay";
-- phy-mode = "sgmii";
-+ phy-mode = "sgmii-2500";
-+ managed = "in-band-status";
- phy = <&ethphy0>;
-- fixed-link {
-- speed = <1000>;
-- full-duplex;
-- };
- };
-
- &eth1 {
- status = "okay";
-- phy-mode = "sgmii";
-+ phy-mode = "sgmii-2500";
-+ managed = "in-band-status";
- phy = <&ethphy1>;
-- fixed-link {
-- speed = <1000>;
-- full-duplex;
-- };
- };
-
- &i2c0 {