aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-omap/Makefile
diff options
context:
space:
mode:
authorAndre Heider <a.heider@gmail.com>2019-09-06 11:25:30 +0200
committerAlexander Couzens <lynxis@fe80.eu>2019-11-20 10:46:19 +0100
commitb69df1eee0eb4618355d5ea4d0cdb4553475c4b7 (patch)
tree495c0252af31d905eeb7faef6d8805db878c59b0 /package/boot/uboot-omap/Makefile
parent65cfe8164ae9e3965e45d68dd9649fc9784dc2a0 (diff)
downloadupstream-b69df1eee0eb4618355d5ea4d0cdb4553475c4b7.tar.gz
upstream-b69df1eee0eb4618355d5ea4d0cdb4553475c4b7.tar.bz2
upstream-b69df1eee0eb4618355d5ea4d0cdb4553475c4b7.zip
omap: update uboot to 2019.10
All patches have been dropped, they're either redundant (e.g. due to the new and unset CONFIG_SPL_FAT_WRITE), break compilation (thumb hacks) or have been applied upstream. The defconfig for am335x_boneblack has been removed upstream [0], so use am335x_evm for boneblack too. Size changes (before, after, file): ti_am335x-evm and ti_am335x-bone-black: 79804 110832 MLO 623836 756148 u-boot.img ti_omap3-beagle: 54148 57708 MLO 496272 665728 u-boot.img ti_omap4-panda: 39356 40204 MLO 284648 366672 u-boot.img Tested on boneblack, which has the biggest spl size increase. The beagle and panda spl sizes seem reasonable to not break booting. [0] https://gitlab.denx.de/u-boot/u-boot/commit/8fa7f65dd02c176ee6021eaf40114560b8954ba2 Signed-off-by: Andre Heider <a.heider@gmail.com>
Diffstat (limited to 'package/boot/uboot-omap/Makefile')
-rw-r--r--package/boot/uboot-omap/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/package/boot/uboot-omap/Makefile b/package/boot/uboot-omap/Makefile
index f2a26796d8..b519d6fb80 100644
--- a/package/boot/uboot-omap/Makefile
+++ b/package/boot/uboot-omap/Makefile
@@ -8,10 +8,10 @@
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
-PKG_VERSION:=2017.01
-PKG_RELEASE:=4
+PKG_VERSION:=2019.10
+PKG_RELEASE:=1
-PKG_HASH:=6c425175f93a4bcf2ec9faf5658ef279633dbd7856a293d95bd1ff516528ecf2
+PKG_HASH:=8d6d6070739522dd236cba7055b8736bfe92b4fac0ea18ad809829ca79667014
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
@@ -27,14 +27,9 @@ define U-Boot/omap4_panda
BUILD_DEVICES:=ti_omap4-panda
endef
-define U-Boot/am335x_boneblack
- NAME:=TI AM335x BeagleBone Black
- BUILD_DEVICES:=ti_am335x-bone-black
-endef
-
define U-Boot/am335x_evm
NAME:=AM335x EVM
- BUILD_DEVICES:=ti_am335x-evm
+ BUILD_DEVICES:=ti_am335x-evm ti_am335x-bone-black
endef
define U-Boot/omap3_overo
@@ -46,12 +41,18 @@ define U-Boot/omap3_beagle
BUILD_DEVICES:=ti_omap3-beagle
endef
-UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle am335x_boneblack
+UBOOT_TARGETS:=omap4_panda am335x_evm omap3_overo omap3_beagle
define Build/InstallDev
- $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)
- $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/
- $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(BUILD_DEVICES)/uEnv.txt
+ $(foreach device,$(BUILD_DEVICES), \
+ $(INSTALL_DIR) $(STAGING_DIR_IMAGE)/$(device)
+ )
+ $(foreach device,$(BUILD_DEVICES), \
+ $(CP) $(patsubst %,$(PKG_BUILD_DIR)/%,$(UBOOT_IMAGE)) $(STAGING_DIR_IMAGE)/$(device)/
+ )
+ $(foreach device,$(BUILD_DEVICES), \
+ $(CP) ./files/uEnv-$(UENV).txt $(STAGING_DIR_IMAGE)/$(device)/uEnv.txt
+ )
endef
$(eval $(call BuildPackage/U-Boot))