aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-07-10 17:38:36 +0200
committerDavid Bauer <mail@david-bauer.net>2020-07-28 15:52:44 +0200
commit04f06787f1c0f1d89f6b8c71430d0d0bbb62ffa5 (patch)
tree27b246e3ca941dab01d39c700fb9d7f40f852fb1 /package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch
parent65ac670b792481d921f3aaba685d4c9910e1ad04 (diff)
downloadupstream-04f06787f1c0f1d89f6b8c71430d0d0bbb62ffa5.tar.gz
upstream-04f06787f1c0f1d89f6b8c71430d0d0bbb62ffa5.tar.bz2
upstream-04f06787f1c0f1d89f6b8c71430d0d0bbb62ffa5.zip
uboot-rockchip: add NanoPi R2S support
Add support for the FriendlyARM NanoPi R2S. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch')
-rw-r--r--package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch b/package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch
new file mode 100644
index 0000000000..4161c46ce2
--- /dev/null
+++ b/package/boot/uboot-rockchip/patches/002-spl-remove-dtoc-of-pdata-generation.patch
@@ -0,0 +1,32 @@
+From 55273cf6079ddd3b006da69f0113c2c66c03f17e Mon Sep 17 00:00:00 2001
+From: David Bauer <mail@david-bauer.net>
+Date: Tue, 14 Jul 2020 22:44:22 +0200
+Subject: [PATCH] spl: remove dtoc of-pdata generation
+
+Remove the dtoc of-pdata generation. This generation is dependant on
+libpython-dev. As OpenWrt does not ship with this dependency, use
+pre-generated pdata files and remove the generation from the
+build-process.
+
+This only affects RK3328 boards.
+
+Signed-off-by: David Bauer <mail@david-bauer.net>
+---
+ scripts/Makefile.spl | 6 ------
+ 1 file changed, 6 deletions(-)
+
+--- a/scripts/Makefile.spl
++++ b/scripts/Makefile.spl
+@@ -320,12 +320,6 @@ PHONY += dts_dir
+ dts_dir:
+ $(shell [ -d $(obj)/dts ] || mkdir -p $(obj)/dts)
+
+-include/generated/dt-structs-gen.h: $(obj)/$(SPL_BIN).dtb dts_dir FORCE
+- $(call if_changed,dtoch)
+-
+-$(obj)/dts/dt-platdata.c: $(obj)/$(SPL_BIN).dtb dts_dir FORCE
+- $(call if_changed,dtocc)
+-
+ ifdef CONFIG_SAMSUNG
+ ifdef CONFIG_VAR_SIZE_SPL
+ VAR_SIZE_PARAM = --vs