aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-rockchip/patches
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-07-10 15:14:15 +0200
committerDavid Bauer <mail@david-bauer.net>2020-07-28 15:52:44 +0200
commit65ac670b792481d921f3aaba685d4c9910e1ad04 (patch)
tree838f7625bc1bc83331bc6c099098c95d98526261 /package/boot/uboot-rockchip/patches
parent444b107118212b4b5e822b9eb0937019dde1a4a1 (diff)
downloadupstream-65ac670b792481d921f3aaba685d4c9910e1ad04.tar.gz
upstream-65ac670b792481d921f3aaba685d4c9910e1ad04.tar.bz2
upstream-65ac670b792481d921f3aaba685d4c9910e1ad04.zip
uboot-rockchip: update to v2020.07
Update the U-Boot to version v2020.07. Also replace the Makefile rewrite with a proper patch, explaining why this hack is needed. Run-tested: FriendlyARM NanoPi R2S Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'package/boot/uboot-rockchip/patches')
-rw-r--r--package/boot/uboot-rockchip/patches/001-scripts-remove-dependency-on-swig.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/package/boot/uboot-rockchip/patches/001-scripts-remove-dependency-on-swig.patch b/package/boot/uboot-rockchip/patches/001-scripts-remove-dependency-on-swig.patch
new file mode 100644
index 0000000000..0505589385
--- /dev/null
+++ b/package/boot/uboot-rockchip/patches/001-scripts-remove-dependency-on-swig.patch
@@ -0,0 +1,24 @@
+From b137ca16b54c67d76714ea5a0138741959b0dc29 Mon Sep 17 00:00:00 2001
+From: David Bauer <mail@david-bauer.net>
+Date: Mon, 13 Jul 2020 23:37:37 +0200
+Subject: [PATCH] scripts: remove dependency on swig
+
+Don't build the libfdt tool, as it has a dependency on swig (which
+OpenWrt does not ship).
+
+This requires more hacks, as of-platdata generation does not work
+without it.
+
+Signed-off-by: David Bauer <mail@david-bauer.net>
+---
+ scripts/dtc/Makefile | 2 --
+ 1 file changed, 2 deletions(-)
+
+--- a/scripts/dtc/Makefile
++++ b/scripts/dtc/Makefile
+@@ -18,5 +18,3 @@ HOSTCFLAGS_dtc-parser.tab.o := -I$(src)
+ # dependencies on generated files need to be listed explicitly
+ $(obj)/dtc-lexer.lex.o: $(obj)/dtc-parser.tab.h
+
+-# Added for U-Boot
+-subdir-$(CONFIG_PYLIBFDT) += pylibfdt