aboutsummaryrefslogtreecommitdiffstats
path: root/package/boot/uboot-zynq/Makefile
diff options
context:
space:
mode:
authorJo-Philipp Wich <jo@mein.io>2018-05-23 09:32:25 +0200
committerJo-Philipp Wich <jo@mein.io>2018-05-23 09:32:25 +0200
commit1289e00fffaebad7ab1a9cec33c7b0472edb4527 (patch)
treed4293cb80f3e29f8c6d84e18fecbe375e0cb4826 /package/boot/uboot-zynq/Makefile
parent208b984dda0c2348d425b992b9a1c171d5aaa8e8 (diff)
downloadupstream-1289e00fffaebad7ab1a9cec33c7b0472edb4527.tar.gz
upstream-1289e00fffaebad7ab1a9cec33c7b0472edb4527.tar.bz2
upstream-1289e00fffaebad7ab1a9cec33c7b0472edb4527.zip
uboot-zynq: fix build on hosts lacking pkg-config
The uboot-mvebu package incorrectly used the host pkg-config for the tool build parts, which broke the build on systems lacking pkg-config and only worked by accident on those that have it installed. Export the host-build specific environment variables for the uboot build to redirect pkg-config invocations to our staged host build pkg-config in buildroot. Signed-off-by: Jo-Philipp Wich <jo@mein.io>
Diffstat (limited to 'package/boot/uboot-zynq/Makefile')
-rw-r--r--package/boot/uboot-zynq/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/boot/uboot-zynq/Makefile b/package/boot/uboot-zynq/Makefile
index d25ecfb4bb..736ebd26da 100644
--- a/package/boot/uboot-zynq/Makefile
+++ b/package/boot/uboot-zynq/Makefile
@@ -14,6 +14,7 @@ PKG_HASH:=e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb
include $(INCLUDE_DIR)/kernel.mk
include $(INCLUDE_DIR)/u-boot.mk
include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
define U-Boot/Default
BUILD_TARGET:=zynq
@@ -42,4 +43,6 @@ UBOOT_TARGETS := \
zed \
zybo
+Build/Exports:=$(Host/Exports)
+
$(eval $(call BuildPackage/U-Boot))