aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-09-21 13:25:11 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-09-21 13:25:11 +0000
commit61a94268ec17c6da65a21ab64ae10aeca70347f5 (patch)
tree8ebe709a5db8ab015ab2b26e079da06126f47c0b /package/dnsmasq/Makefile
parent9474d99dc0179527581850e2abbce49bb81ef1f1 (diff)
downloadupstream-61a94268ec17c6da65a21ab64ae10aeca70347f5.tar.gz
upstream-61a94268ec17c6da65a21ab64ae10aeca70347f5.tar.bz2
upstream-61a94268ec17c6da65a21ab64ae10aeca70347f5.zip
Add default /etc/dnsmasq.conf
dnsmasq allows adding of arbitrary SRV/PTR/TXT/CNAME records. However, those options sometimes can not be passed as command-line arguments due to excess length. This patch tries to solve this problem: 1. Provide /etc/dnsmasq.conf file with comments about adding SRV/PTR/TXT/CNAME records. 2. Add this file to conffiles list so it is preserver during backup/restore or system upgrade. If someone needs a lot of custom records, default configuration file can be edited. Since manual pages and documentation is not installed, provided comments should be enough to figure out option syntax. Signed-off-by: Alexey I. Froloff <raorn@altlinux.org> SVN-Revision: 17663
Diffstat (limited to 'package/dnsmasq/Makefile')
-rw-r--r--package/dnsmasq/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 3444efefff..176e5b93d3 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -30,6 +30,7 @@ endef
define Package/dnsmasq/conffiles
/etc/config/dhcp
+/etc/dnsmasq.conf
endef
define Build/Compile
@@ -46,6 +47,7 @@ define Package/dnsmasq/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/dnsmasq $(1)/usr/sbin/
$(INSTALL_DIR) $(1)/etc/config
$(INSTALL_DATA) ./files/dhcp.conf $(1)/etc/config/dhcp
+ $(INSTALL_DATA) ./files/dnsmasq.conf $(1)/etc/dnsmasq.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/dnsmasq.init $(1)/etc/init.d/dnsmasq
endef