aboutsummaryrefslogtreecommitdiffstats
path: root/package/dnsmasq
diff options
context:
space:
mode:
authorTravis Kemen <thepeople@openwrt.org>2008-03-26 16:26:59 +0000
committerTravis Kemen <thepeople@openwrt.org>2008-03-26 16:26:59 +0000
commit6703cacfdea10dbc134e25bca0d67ea425ec8299 (patch)
treea514af719d14a1d50717a79d87f8864243da73ec /package/dnsmasq
parentb2387fc537cdea126aaa7c1d8ca191a5d7b37b9d (diff)
downloadupstream-6703cacfdea10dbc134e25bca0d67ea425ec8299.tar.gz
upstream-6703cacfdea10dbc134e25bca0d67ea425ec8299.tar.bz2
upstream-6703cacfdea10dbc134e25bca0d67ea425ec8299.zip
This upgrades dnsmasq-2.40 to dnsmasq-2.41. Signed-off-by: Alexandros C. Couloumbis <alex at ozo.com>
SVN-Revision: 10663
Diffstat (limited to 'package/dnsmasq')
-rw-r--r--package/dnsmasq/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/dnsmasq/Makefile b/package/dnsmasq/Makefile
index 6297965779..6e4c2229c4 100644
--- a/package/dnsmasq/Makefile
+++ b/package/dnsmasq/Makefile
@@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=dnsmasq
-PKG_VERSION:=2.40
+PKG_VERSION:=2.41
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
-PKG_MD5SUM:=91b6063ae81146b9d70b4381b2f3e44f
+PKG_MD5SUM:=b067598c3e9b91819a8be5cb59cbf90e
include $(INCLUDE_DIR)/package.mk
background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
#
#             LUFA Library
#     Copyright (C) Dean Camera, 2012.
#
#  dean [at] fourwalledcubicle [dot] com
#           www.lufa-lib.org
#

# Makefile to build all the LUFA Projects. Call with "make all" to
# rebuild all projects.

# Projects are pre-cleaned before each one is built, to ensure any
# custom LUFA library build options are reflected in the compiled
# code.

PROJECT_DIRECTORIES := $(shell ls -d */)

# This makefile is potentially infinitely recursive if something really bad
# happens when determining the set of project directories - hard-abort if
# more than 10 levels deep to avoid angry emails.
ifeq ($(MAKELEVEL), 10)
   $(error EMERGENCY ABORT: INFINITE RECURSION DETECTED)
endif

# Need to special-case building without a per-project object directory
ifeq ($(OBJDIR),)
   # If no target specified, force "clean all" and disallow parallel build   
   ifeq ($(MAKECMDGOALS),)
      MAKECMDGOALS := clean all
      .NOTPARALLEL:
   endif

   # If one of the targets is to build, force "clean" beforehand and disallow parallel build   
   ifneq ($(findstring all, $(MAKECMDGOALS)),)
      MAKECMDGOALS := clean $(MAKECMDGOALS)
      .NOTPARALLEL:
   endif
endif

%: $(PROJECT_DIRECTORIES)
	@echo . > /dev/null

$(PROJECT_DIRECTORIES):
	@$(MAKE) -C $@ $(MAKECMDGOALS)
    
.PHONY: $(PROJECT_DIRECTORIES)