aboutsummaryrefslogtreecommitdiffstats
path: root/package/e2fsprogs
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-05-11 10:33:34 +0000
committerNicolas Thill <nico@openwrt.org>2008-05-11 10:33:34 +0000
commit2b05ed626c650657e29575f209ea80e6553f8a55 (patch)
tree4467bf45f1dc745771bf8381a437d25897d63afc /package/e2fsprogs
parent28a650e13a261fbc463ae41a55bf7012b60e53e3 (diff)
downloadupstream-2b05ed626c650657e29575f209ea80e6553f8a55.tar.gz
upstream-2b05ed626c650657e29575f209ea80e6553f8a55.tar.bz2
upstream-2b05ed626c650657e29575f209ea80e6553f8a55.zip
add a package for the badblocks utility (closes: #3404)
SVN-Revision: 11107
Diffstat (limited to 'package/e2fsprogs')
-rw-r--r--package/e2fsprogs/Makefile14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/e2fsprogs/Makefile b/package/e2fsprogs/Makefile
index a30aea7ed8..983b90b500 100644
--- a/package/e2fsprogs/Makefile
+++ b/package/e2fsprogs/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -84,6 +84,12 @@ $(call Package/e2fsprogs)
DEPENDS:=e2fsprogs
endef
+define Package/badblocks
+$(call Package/e2fsprogs)
+ TITLE:=Ext2 Filesystem badblocks utility
+ DEPENDS:=e2fsprogs
+endef
+
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
@@ -151,9 +157,15 @@ define Package/resize2fs/install
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/resize2fs $(1)/usr/sbin/
endef
+define Package/badblocks/install
+ $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/badblocks $(1)/usr/sbin/
+endef
+
$(eval $(call BuildPackage,e2fsprogs))
$(eval $(call BuildPackage,libuuid))
$(eval $(call BuildPackage,uuidgen))
$(eval $(call BuildPackage,libblkid))
$(eval $(call BuildPackage,tune2fs))
$(eval $(call BuildPackage,resize2fs))
+$(eval $(call BuildPackage,badblocks))