aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/fman-ucode/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-07-03 10:48:27 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit2e2203ff72fd1556bab2c32e808ce7bb79a9858c (patch)
tree607f010eaac6a2830d92ac07e7ae8ab566b5e049 /package/firmware/fman-ucode/Makefile
parent806624add541bd828516a58aab20ae19ae9e431f (diff)
downloadupstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.tar.gz
upstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.tar.bz2
upstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.zip
layerscape: update packages with LSDK git trees
NXP Layerscape LSDK had set up its own open source web site and github for release. https://lsdk.github.io https://github.com/qoriq-open-source This patch is to update rcw/fman_ucode/u-boot packages with LSDK git trees. Also add some patches of packages to support LEDE. Since ARMv8 32-bit u-boot images are same with ARMv8 64-bit images but 64-bit toolchain couldn't be used for 32-bit targets, we still use a private tree for ARMv8 32-bit u-boot images. This is in plan to move this private tree to NXP Layerscape github. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/firmware/fman-ucode/Makefile')
-rw-r--r--package/firmware/fman-ucode/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/package/firmware/fman-ucode/Makefile b/package/firmware/fman-ucode/Makefile
index 396750f804..e2969323e4 100644
--- a/package/firmware/fman-ucode/Makefile
+++ b/package/firmware/fman-ucode/Makefile
@@ -9,19 +9,16 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
PKG_NAME:=fman-ucode
-PKG_VERSION:=fsl-sdk-v2.0
+PKG_VERSION:=2017.09
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
-PKG_MIRROR_HASH:=209c60e4efaa3ce9c9a954266a7210fa0047a2de47ce00a412aa0318d94d0d88
-PKG_SOURCE_URL:=https://github.com/fsl-jyt/fm-ucode.git
-PKG_SOURCE_VERSION:=b19c645821941493fbef32e616b5a16404259976
+PKG_SOURCE_URL:=https://github.com/qoriq-open-source/fm-ucode.git
+PKG_SOURCE_VERSION:=c275e91392e2adab1ed22f3867b8269ca3c54014
+PKG_MIRROR_HASH:=80d8d2454063b7f730ef49d7a44be8f8870711ee5109c53a0881b62026037a37
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
-
PKG_FLAGS:=nonshared
include $(INCLUDE_DIR)/package.mk
@@ -33,12 +30,12 @@ endef
define fman/ls1043ardb
TITLE=FMAN UCODE $(PKG_NAME)-$(PKG_VERSION) for NXP ls1043ardb 64b/32b Dev Board
- CONFIG=fsl_fman_ucode_ls1043_r1.0_108_4_5.bin
+ CONFIG=fsl_fman_ucode_ls1043_r1.1_106_4_18.bin
endef
define fman/ls1046ardb
TITLE=FMAN UCODE $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
- CONFIG=fsl_fman_ucode_t2080_r1.1_106_4_18.bin
+ CONFIG=fsl_fman_ucode_ls1046_r1.0_106_4_18.bin
endef
FMANS := \
@@ -51,7 +48,7 @@ define Package/fman-layerscape-$(1)
CATEGORY:=Firmware
DEPENDS:=@TARGET_layerscape
TITLE:=$(2)
- URL:=http://git.freescale.com/git/cgit.cgi/ppc/sdk/fm-ucode.git
+ URL:=https://github.com/qoriq-open-source/fm-ucode.git
VARIANT:=$(1)
MAINTAINER:=Jiang Yutang <jiangyutang1978@gmail.com>
endef