aboutsummaryrefslogtreecommitdiffstats
path: root/package/firmware/rcw/Makefile
diff options
context:
space:
mode:
authorYangbo Lu <yangbo.lu@nxp.com>2017-07-03 10:48:27 +0800
committerJohn Crispin <john@phrozen.org>2017-10-07 23:13:22 +0200
commit2e2203ff72fd1556bab2c32e808ce7bb79a9858c (patch)
tree607f010eaac6a2830d92ac07e7ae8ab566b5e049 /package/firmware/rcw/Makefile
parent806624add541bd828516a58aab20ae19ae9e431f (diff)
downloadupstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.tar.gz
upstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.tar.bz2
upstream-2e2203ff72fd1556bab2c32e808ce7bb79a9858c.zip
layerscape: update packages with LSDK git trees
NXP Layerscape LSDK had set up its own open source web site and github for release. https://lsdk.github.io https://github.com/qoriq-open-source This patch is to update rcw/fman_ucode/u-boot packages with LSDK git trees. Also add some patches of packages to support LEDE. Since ARMv8 32-bit u-boot images are same with ARMv8 64-bit images but 64-bit toolchain couldn't be used for 32-bit targets, we still use a private tree for ARMv8 32-bit u-boot images. This is in plan to move this private tree to NXP Layerscape github. Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/firmware/rcw/Makefile')
-rw-r--r--package/firmware/rcw/Makefile21
1 files changed, 9 insertions, 12 deletions
diff --git a/package/firmware/rcw/Makefile b/package/firmware/rcw/Makefile
index bae9c95b6c..a065385189 100644
--- a/package/firmware/rcw/Makefile
+++ b/package/firmware/rcw/Makefile
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
PKG_NAME:=rcw
-PKG_VERSION:=v1.0
+PKG_VERSION:=2017.09
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
-PKG_MIRROR_HASH:=8082979dbdef57e36a3096986aa426ef678c152403eb1dbd132da28f01490b6d
-PKG_SOURCE_URL:=https://github.com/fsl-jyt/rcw.git
-PKG_SOURCE_VERSION:=17e09e19bd5cf94e5ebc84916b4607743c29723e
+PKG_SOURCE_URL:=https://github.com/qoriq-open-source/rcw.git
+PKG_SOURCE_VERSION:=1a6236a34166219de324a105971eb9de05cde76e
+PKG_MIRROR_HASH:=6da17ad6b4d148bd991a85bf601f845a41231d6f0bf20153ba1a7a387727aef0
PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_LICENSE:=GPL-2.0 GPL-2.0+
-PKG_LICENSE_FILES:=Licenses/README
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
PKG_FLAGS:=nonshared
@@ -33,17 +33,17 @@ endef
define rcw/ls1043ardb
TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1043ardb 64b/32b Dev Board
- CONFIG=ls1043ardb-rcw.bin
+ CONFIG=ls1043ardb/RR_FQPP_1455/rcw_1600.bin
endef
define rcw/ls1046ardb
TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
- CONFIG=ls1046ardb-rcw.bin
+ CONFIG=ls1046ardb/RR_FFSSPPPH_1133_5559/rcw_1800_qspiboot_swap.bin
endef
define rcw/ls1012ardb
TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 64b/32b Dev Board
- CONFIG=ls1012ardb-rcw.bin
+ CONFIG=ls1012ardb/R_SPNH_3508/PBL_0x35_0x08_800_250_1000_default.bin
endef
RCWS := \
@@ -77,9 +77,6 @@ endif
define Build/Configure
endef
-define Build/Compile
-endef
-
define Package/rcw/install/default
$(INSTALL_DIR) $(STAGING_DIR_IMAGE)
$(CP) $(PKG_BUILD_DIR)/$(RCW_CONFIG) $(STAGING_DIR_IMAGE)/$(1)-rcw.bin