aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostap-driver
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-16 16:21:56 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-16 16:21:56 +0000
commit9ad89ea9cb6554cda5898e95728292a0824eeec5 (patch)
treeabb57ac2b2587a4d6050be0a1b13e41ccfbfba10 /package/hostap-driver
parent6226b53b1b928004d00c869305ea4cb55ace7f17 (diff)
downloadupstream-9ad89ea9cb6554cda5898e95728292a0824eeec5.tar.gz
upstream-9ad89ea9cb6554cda5898e95728292a0824eeec5.tar.bz2
upstream-9ad89ea9cb6554cda5898e95728292a0824eeec5.zip
add missing dependencies on PCI/PCMCIA/USB support
SVN-Revision: 8801
Diffstat (limited to 'package/hostap-driver')
-rw-r--r--package/hostap-driver/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hostap-driver/Makefile b/package/hostap-driver/Makefile
index 9ade13ec65..b784131a1d 100644
--- a/package/hostap-driver/Makefile
+++ b/package/hostap-driver/Makefile
@@ -70,7 +70,7 @@ endef
define KernelPackage/hostap-pci
$(call KernelPackage/hostap/Default)
- DEPENDS:=kmod-hostap
+ DEPENDS:=@PCI_SUPPORT kmod-hostap
TITLE:=Host AP driver for PCI adaptors
KCONFIG:=CONFIG_HOSTAP_PCI
AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
@@ -91,7 +91,7 @@ endef
define KernelPackage/hostap-plx
$(call KernelPackage/hostap/Default)
- DEPENDS:=kmod-hostap
+ DEPENDS:=@PCI_SUPPORT kmod-hostap
KCONFIG:=CONFIG_HOSTAP_PLX
TITLE:=Host AP driver for PLX9052 based PCI adaptors
AUTOLOAD:=$(call AutoLoad,60,hostap_plx)